cancel
Showing results for 
Search instead for 
Did you mean: 

Your manifest includes permissions restricted by Oculus: - android.permission.RECORD_AUDIO

Hey guys I'm trying to submit my build online. However I'm getting this issue for some reason from the dashboard.

 

"Your manifest includes the following permissions restricted by Oculus: - android.permission.RECORD_AUDIO Please remove these permissions if they are not needed by your application. If they are needed, you must include justification above. Failure to provide justification will result in rejection of your application." Here is a look at my Manifest.

 

<?xml version="1.0" encoding="utf-8" standalone="no"?>

<manifest xmlns:android="http://schemas.android.com/apk/res/android" android:installLocation="auto"> <application android:label="@string/app_name" android:icon="@mipmap/app_icon" android:allowBackup="false"> <activity android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen" android:configChanges="locale|fontScale|keyboard|keyboardHidden|mcc|mnc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|touchscreen|uiMode" android:launchMode="singleTask" android:name="com.unity3d.player.UnityPlayerActivity" android:excludeFromRecents="true">

<intent-filter>

<action android:name="android.intent.action.MAIN" />

<category android:name="android.intent.category.LAUNCHER" />

</intent-filter> </activity> <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="false" /> <meta-data android:name="com.samsung.android.vr.application.mode" android:value="vr_only" />

<meta-data android:name="com.oculus.vr.focusaware" android:value="true"/>

</application>

<uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" /> </manifest>

 

I've tried using the solution mentioned here https://forums.oculusvr.com/t5/Platform-SDK-Development/Unnecessary-permission-RECORD-AUDIO-in-Platf..., but to no avail

2 REPLIES 2

aspen1024
Level 2

Hello, Did you solve this problem? I have the same problem too, dont know ow to solve it, maybe comment out or disable the Oculus microphone code?

 

Hey you don't need to do any of that just replace manifest file with the code below. You should be good to go.

 

<?xml version="1.0" encoding="utf-8" standalone="no"?>

<manifest xmlns:android="http://schemas.android.com/apk/res/android"

    package="com.example.myapp"

    xmlns:tools="http://schemas.android.com/tools">

    <uses-permission android:name="android.permission.RECORD_AUDIO" tools:node="remove"/>

    <application android:label="@string/app_name" android:icon="@mipmap/app_icon" android:allowBackup="false">

    <activity android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen" android:configChanges="locale|fontScale|keyboard|keyboardHidden|mcc|mnc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|touchscreen|uiMode" android:launchMode="singleTask" android:name="com.unity3d.player.UnityPlayerActivity" android:excludeFromRecents="true">

      <intent-filter>

        <action android:name="android.intent.action.MAIN" />

        <category android:name="android.intent.category.LAUNCHER" />

      </intent-filter>

    </activity>

    <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="false" />

    <meta-data android:name="com.samsung.android.vr.application.mode" android:value="vr_only" />

    <meta-data android:name="com.oculus.vr.focusaware" android:value="true"/>

  </application>

  <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" />

</manifest>

<?xml version="1.0" encoding="utf-8" standalone="no"?>

<manifest xmlns:android="http://schemas.android.com/apk/res/android"

    package="com.example.myapp"

    xmlns:tools="http://schemas.android.com/tools">

    <uses-permission android:name="android.permission.RECORD_AUDIO" tools:node="remove"/>

    <application android:label="@string/app_name" android:icon="@mipmap/app_icon" android:allowBackup="false">

    <activity android:theme="@android:style/Theme.Black.NoTitleBar.Fullscreen" android:configChanges="locale|fontScale|keyboard|keyboardHidden|mcc|mnc|navigation|orientation|screenLayout|screenSize|smallestScreenSize|touchscreen|uiMode" android:launchMode="singleTask" android:name="com.unity3d.player.UnityPlayerActivity" android:excludeFromRecents="true">

      <intent-filter>

        <action android:name="android.intent.action.MAIN" />

        <category android:name="android.intent.category.LAUNCHER" />

      </intent-filter>

    </activity>

    <meta-data android:name="unityplayer.SkipPermissionsDialog" android:value="false" />

    <meta-data android:name="com.samsung.android.vr.application.mode" android:value="vr_only" />

    <meta-data android:name="com.oculus.vr.focusaware" android:value="true"/>

  </application>

  <uses-feature android:name="android.hardware.vr.headtracking" android:version="1" android:required="true" />

</manifest>