Showing results for 
Search instead for 
Did you mean: 

upgrading project for quest

Level 2
I am trying to upgrade a project that was made for the samsung gear ages ago for the quest using unity, just transferring the pre-built APK worked fine (just running it obviously the controls didn't work). however when I am trying to re-build from unity to the quest I am running into all sorts of issues, firstly the project was created on unity 2017.1.1 and when using the JDK 12 I got compatability issues with target and source 1.6 so I changed JDK to 8 which worked however the build would freeze unity after copying to the quest and then trying to run it would have the app constantly load. Next thing I tried was upgrade the whole project to unity 2019.1.0b1. this required me to change a lot of scripts that were using UnityEngine.VR to instead use UnityEngine.XR which should be just a simple path change no logic change required, this time when I build and run it builds successfully and unity doesn't freeze however the app doesn't run or connect to the debugging tools. Is there something I'm missing?

PS: I have made sure to have the latest version of oculus integration for unity and it is using OVRmanager.
PSS: I have created a test app from scratch that works fine so there must be something specific to this project which is the issue.