cancel
Showing results for 
Search instead for 
Did you mean: 

Cant connect from Quest to a Dedicated server over local network

Skalbe
Level 2
Hi!
I`m trying to create a Hello World of a Quest app connecting to a dedicated server running on the same home wi-fi. As I understand this should work easily.
I`m using the latest 4.24 Oculus UE branch
I can run the server and join it locally thru localip on windows, but when I launch a client on Quest, it only loads up the entry map, the Open blueprint method (ip to my windows server) executes, but nothing happens. The app is running fine, logs show no failures.
I`ve gone through all the server and oculus quest tutorials that I could find, but none really mention this combination that I need. Maybe I`m missing something trivial.
0]LogWorld: Bringing World /QuestHands/Maps/entryMap.entryMap up for play (max tick rate 0) at 2020.07.19-23.59.14
07-19 23:59:14.748 12890 13846 D UE4 : [2020.07.19-20.59.14:748][ 0]LogWorld: Bringing up level for play took: 0.001067
07-19 23:59:14.749 12890 13846 D UE4 : [2020.07.19-20.59.14:749][ 0]LogGameMode: FindPlayerStart: PATHS NOT DEFINED or NO PLAYERSTART with positive rating
07-19 23:59:14.750 12890 13846 D UE4 : [2020.07.19-20.59.14:750][ 0]LogVoiceEncode: Display: EncoderVersion: libopus unknown-fixed
07-19 23:59:14.750 12890 13846 D UE4 : [2020.07.19-20.59.14:750][ 0]LogVoiceEngine: Error: OSS: StopLocalVoiceProcessing: Ignoring stop request for non-owning user
07-19 23:59:14.751 12890 13846 D UE4 : [2020.07.19-20.59.14:751][ 0]LogOnlineVoice: OSS: StopLocalVoiceProcessing(0) returned 0xFFFFFFFF
07-19 23:59:14.751 12890 13846 D UE4 : [2020.07.19-20.59.14:751][ 0]LogOnlineVoice: OSS: Stopping networked voice for user: 0
07-19 23:59:14.752 12890 13846 D UE4 : [2020.07.19-20.59.14:752][ 0]LogBlueprintUserMessages: [entryMap_C_0] TRIED LOADING SERVER MAP
07-19 23:59:14.755 12890 13846 D UE4 : [2020.07.19-20.59.14:754][ 0]LogMR: MRC Initialized
07-19 23:59:14.752 12890 13846 D UE4 : [2020.07.19-20.59.14:752][ 0]LogBlueprintUserMessages: [entryMap_C_0] TRIED LOADING SERVER MAP
this is a bit between loading up the entry map and executing Print statement after my Open command.

warmth and thanks.
2 REPLIES 2

dsolod
Level 2

Hi Skalbe,

I am facing the same problem

Have you figured it out just in case?

Thank you in advance

VintageGreen
Level 5

Join Session never sees the correct map loaded on the server host user's headset two headsets cannot connect to each other right now using Unreal engine