cancel
Showing results for 
Search instead for 
Did you mean: 

[QUEST 2] Can't get the friend list

Bidonjour
Level 2

Hello,

 

I'm trying to get the current list of connected friends. I'm working with two Oculus Quest 2 headsets with different Facebook accounts. The 2 accounts are friend with each other. My starting point is the Oculus SDK Unreal sample (V 28.0), I'm using the Online Friend List Widget. When I open the map containing this widget, the list of friends is always empty even if I push the Refresh button. It's also empty even if the two players are connected on the application. I've tried some debugging by adding logs in OnlineFriendsInterfaceOculus.cpp, in FOnlineFriendsOculus::OnQueryFriendsComplete(), UserNum is always equal to 0, I guess it means that no friend has been found by OVR, but I can't debug this part unfortunately...

 

Note that I have no issue with the matchmaking feature, atfer struggling a lot I've made it work, but I'm not able to get the friends feature working ... I woul really appreciate if someone make it works have any idea about how to fix it.

 

Thanks

3 REPLIES 3

Bidonjour
Level 2

I'm still interested by the way if someone has any idea ...

Open your app on the Oculus Dashboard, and go to "Data Use Checkup" on the menu bar on the left. Have you requested "Friend" data access from your app (its near the bottom)? You will also need to request "User ID" and "Profile" access to get proper user id's, etc.

 

Last time I created an app and requested any data usage, the process seemed a bit complicated and I wasnt sure how to answer all of the questions, but I the approval came back very quickly ... to the point where I'm pretty sure it was just an automatic approval, and no one actually read my request. But that was a while ago, and possiblly its a bit more Facebook-hands-on now.

 

One more thing that I had an issue with was the "Submit" buttons at the bottom. The "Add" and "Manage" buttons on the right seem like they would actually send the request, but you actually have to watch the text on the bottom buttons... it changes to something like "send all" and clicking THAT sends the actual request (IIRC).

 

Guess I just get confused easily (LOL).

 

Hope this was your issue.

Bidonjour
Level 2

Thanks a lot taking the time to answer me. Unfortunately I forgot to mention that the feature "Friends" is approved in the "Data Use Checkup" menu.

 

I've just tried to click on the "Manage" button to send another request to get the "Friends" feature approval again. I'm not really optimistic about this though.

 

Thanks again to try to help me 🙂

 

By the way I'm still very interested if someone has any idea. It's been 2 months I can't go ahead on my project because of this issue.