cancel
Showing results for 
Search instead for 
Did you mean: 

[StereoLayerComponent] I turned on the Supports Depth Flag to build and use Oculus Quest Error

hellop1013
Level 2

The Stereo Layer Component is used for widget use. However, due to the phenomenon that the player hand is drawn behind the widget

I turned on the Supports Depth Flag to build and use Oculus Quest, but it comes out with a black background with no alpha behind.

Does anyone know how to fix it?

When I turn off the Supports Depth Flag, the alpha is fine and the hand is drawn behind the widget.

Unreal Engine Version 4.24

q3kr10qwe19z.png

2 REPLIES 2

en-austin
Level 4
Hi,

I've encountered the same problem with the Stereo Layer Component. If you are building the engine from the Oculus fork I have a few commits to address this in my fork of the engine here.

There are several different problems going on here, but the core cause I found to be the `PokeAHole` material Oculus is using to simulate depth on Quest.

hellop1013
Level 2
Thanks for answering. However, even though the engine code is applied, the same phenomenon occurs.