cancel
Showing results for 
Search instead for 
Did you mean: 

Unreal 4.25.X changes and issues

MaxArch
Level 7
New UE version 4.25 - some changes / issues. Lets put them in one topic for an easy overview and catching up..

4.25.0 preview 1
- Too bad, the new Epic-GPU lightmass plugin is not in this version. Target might be 4.26 (if you build the dev branch you get 4.26)
- When you make a build for Quest, it will fail and you need to install a newer NDK (21). Normally its in the UE extras directory. Not yet. Find it here https://developer.android.com/ndk/downloads ; Download it, extract the zip and put it in the NVPACK dir. Change the Dir in the project settings.
- With the new NDK, building for Quest works but it immediately crashes on Quest. There are a few new project settings but haven't found the right combo yet. ADB logcat has: 'Abort message: 'The requested API version in ovrInitParms (1.1.29.0) is not compatible with this version of VrApi Loader (1.1.31.0)!''. No clue if this is a user setting or a Engine-bug. Reported at Epic.
- update 03-05: tried both building a new project and re-using an existing and working 4.24 project. Both crash on Quest. Only difference is the existing project takes longer to crash.
- update 03-06 "The crash on Quest is known and we're working to have it fixed prior to full 4.25 release."




64 REPLIES 64

MaxArch
Level 7
@motorsep Was just checking. Haven't tested or built anything myself the last month. Too busy with my arch work.

FF_TVegter
Level 2


Hmmm... trying to get our project running on 4.25 (oculus src) again. It still crashes immediatly on the quest, and the log gives me a...

06-12 00:56:07.912 16800 16800 E AndroidRuntime: FATAL EXCEPTION: main
06-12 00:56:07.912 16800 16800 E AndroidRuntime: Process: de.coregames.soar, PID: 16800
06-12 00:56:07.912 16800 16800 E AndroidRuntime: java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "fgets_unlocked" referenced by "/data/app/de.coregames.soar-1/lib/arm64/libUE4.so"...
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at java.lang.Runtime.loadLibrary0(Runtime.java:989)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at java.lang.System.loadLibrary(System.java:1530)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at com.epicgames.ue4.GameActivity.<clinit>(GameActivity.java:6210)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at java.lang.Class.newInstance(Native Method)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at android.app.Instrumentation.newActivity(Instrumentation.java:1079)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2572)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2741)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at android.app.ActivityThread.-wrap12(ActivityThread.java)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1478)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at android.os.Handler.dispatchMessage(Handler.java:102)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at android.os.Looper.loop(Looper.java:154)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at android.app.ActivityThread.main(ActivityThread.java:6165)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at java.lang.reflect.Method.invoke(Native Method)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:886)
06-12 00:56:07.912 16800 16800 E AndroidRuntime: at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:776)

I tried with/without vulkan enabled. I also tried to set "NDK API Level to `android-19`" as suggested by  ikyhdst somewhere above.

@ikyhdst , could you be so kind to show me the rest of your project settings as well? Vulkan? Mobile HDR? I must admit I'm a bit lost here...

I'll try again with the updated 4.25.1 binary from Epic, maybe that gives a better result.

/hauke




Any luck? Stuck at the same point now...

FF_TVegter
Level 2
NKD API level android-21 fixed it for us. (not latest).

sculptrvr
Level 2
I got past the "fgets_unlocked" issue by updating my Quest OS from 19 to 20 and removing a ton of unused plugins. I'm not sure which thing worked.

mpuLs3
Level 2

Has anyone managed to get GPU lightmass (in UE 4.26.2) to work successfully for the Quest / Quest 2 in actually translating the light map information over to the headset? Every time I launch or package it out after the GPU bake, it doesn't seem to work at all, just flat walls with next to no lighting information. Is it not possible yet or am I missing something? 😞 (Pretty sure I'm missing something lol)