cancel
Showing results for 
Search instead for 
Did you mean: 

With 4.25 the .apk name changed - now can't upload to store "Please sign your APK and then resubmit"

Anyone know what I need to do for this?  After updating to Unreal 4.25, it seems that now our .apk for the Quest ends in 'arm64.apk' instead of 'arm-es2.apk'.  I think maybe the uploader is unhappy with that.  Does it expect the name not to change?  How can I fix it? 
9 REPLIES 9

sdmiller
Level 2
I ran into this same issue with a recent build. If I use apksigner (https://developer.android.com/studio/command-line/apksigner) then I can upload it through ovr-platform-util (https://developer.oculus.com/distribute/publish-reference-platform-command-line-utility), but I'm not sure why Unreal stopped doing that automatically

Thank you!  That got the upload to work - although the app won't launch 😞

FF_TVegter
Level 2
Thanks, manually signing it using the apk signer fixed it for us.

MaxSMoke777
Level 2
I don't understand how you use the APKSigner. My keystore is "MaxSMoke.Keystore", not "Keystore.jks". I don't have a certificate file. None of the steps for signing an app for Unreal ever walked us through making a certificate. And what is a key? Is that another file? 

I get the terrible feeling that the Unreal documentation on signing apps is TERRIBLY out of date, as it looks like you guys have a far more complex app signing system now. Come somebody clue me in? I'm just a poor little Blueprint user. :[ 

boy I'm glad they are getting new forums because these do not work very well

deleted duplicate post

Damnit I just typed out a long answer and it erased it.  It should look something like this:

E:\android\android-sdk-windows\build-tools\28.0.3\apksigner.bat sign --ks E:\UnrealProjects\MyGame\Build\Android\MyGame.keystore --ks-key-alias MyGameKey --ks-pass pass:asjs8^$as4!1a78s71 --key-pass pass:aAJasSJJAI*%^A$GA&Hass86 E:\UnrealProjects\MyGame\Archive_Shipping\Android_ASTC\MyGame-Android-Shipping-arm64.apk   

The stupid forums are adding characters to the apk file path above, those should not be there...

The ks-key-alias, ks-pass and key-pass are what you had in the 'Distribution Signing' section of your project settings for Android in UE4.


sure would be nice to be able to delete posts

MaxSMoke777
Level 2
Alexotronic suggested something that enabled me to get an Oculus Platform Window to successfully upload my APK to Oculus's App Lab. He suggested changing the Minimum Target SDK and Target SDK versions from "25" to "23". Once I did that, I was finally able to complete uploading an APK without getting rejected for failing to sign. He said it forced the APK signing from v2 back down to v1.

After NUMEROUS failed attempts installing versions of Android's tools and other things, this was the only thing that seemed to finally break the stalemate I was in with Oculus. 

Also, only 4.26 of UE4 has the checkbox for "Focus Aware". I don't text code my stuff, I only use Blueprints, so I had to use 4.26 to even get that option.