cancel
Showing results for 
Search instead for 
Did you mean: 

ASW doesn't work even when enabled

reinaldo.vieira
Level 3

I'm on the latest oculus branch of ue427, have enabled ASW in the rendering settings and I'm using Oculus Developer Hub to see ASW frames and they come out to 0.

reinaldovieira_1-1661874959650.png

 

I've also enabled experimental features (which is in the wrong place in the plugin because it mentions options below it and there are none below it)

reinaldovieira_0-1661874940525.png

 

6 REPLIES 6

reinaldo.vieira
Level 3

I've also enabled it in the device output and its prints out 1 saying it is enabled, but using ODH and turning on the ASW stats it never passes 0 frames meaning it never kicks on... 

pro_zac
Level 6

Which stat are you looking at in ODH? I looked in the Performance Analyzer but didn't see anything AppSW related. 

 

It should be super obvious when AppSW is enabled if you have OVRmetrics (aka Metrics HUD) open with Average FPS and SpaceWarp FPS. 

reinaldo.vieira
Level 3

reinaldovieira_0-1663853729055.png

thats what I'm using here, it shows off right now cause headset isn't connected but when its on it shows ASW frames 0

If you are seeing the ASW FPS graph in the hud and it stays at 0, then ASW is definitely not on.

 

The step by step instructions are here:

https://developer.oculus.com/documentation/unreal/unreal-asw/#how-to-enable-appsw-in-app

 

tldr: In addition to the "Support Mobile Application Space Warp" checkbox, you need to enable Mobile Multiview, OVRPlugin OpenXR, and Vulkan. Then you need to set r.Mobile.Oculus.SpaceWarp.Enable=True via blueprint or config file.

 

You can also test it out by running this adb command:

adb shell "am broadcast -a android.intent.action.RUN -e cmd 'r.Mobile.Oculus.SpaceWarp.Enable 1'"

reinaldo.vieira
Level 3

Yeah I had followed all the documentation, this is what that ADB command results in: 

-------------------------
2022-09-22 18:01:15.683 ODH executing "adb shell "am broadcast -a android.intent.action.RUN -e cmd 'r.Mobile.Oculus.SpaceWarp.Enable 1'""...

Broadcasting: Intent { act=android.intent.action.RUN flg=0x400000 (has extras) }
Broadcast completed: result=0

I get the same response when I run the command. 

 

Try turning off Instanced Stereo. I see you have that checked in your screenshot, and I definitely don't have that enabled on my project.