cancel
Showing results for 
Search instead for 
Did you mean: 

Networking Broke with UE4.23 [Oculus Branch]

f8i
Level 2
Hey all,
we have a working "join friend via session id" in ue4.22
Simply upgrading our project to the latest 4.23 branch breaks multiplayer.
We get the following errors:

[2019.11.17-15.05.14:528][912]LogPackageName: SearchForPackageOnDisk took   0.025s, but failed to resolve 14123********.umap.
[2019.11.17-15.05.14:528][912]LogNet: Warning: There is no connection to: 0
[2019.11.17-15.05.14:528][912]LogNet: Warning: Server failed post-challenge connection from: 14123********
[2019.11.17-15.05.14:528][912]LogNet: Warning: There is no connection to: 14123********
[2019.11.17-15.05.15:493][972]LogHandshake: SendConnectChallenge. Timestamp: 289.552185, Cookie: 14123********

several times in a row
** i hid the id here.

And this:

[2019.11.17-15.06.29:265][391]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
like hundret times per tick.

Hope you can help



2 REPLIES 2

f8i
Level 2
Thank you! I have been hinted to:
github.com/auzden/UnrealEngine/commit/4d1c0c6c49250e993dd202e576e98f3a0df1e96c
issues.unrealengine.com/issue/UE-82549

Resolved!


I was getting this error after updating to UE4.25.  I looked at that link and it looks like the Oculus code is still the *old* version in 4.25?  I tried this fix and it appears to have worked - WTH?!