cancel
Showing results for 
Search instead for 
Did you mean: 

OVR Lip Sync live capture UE4 Demo not working

Benny-_-
Level 2

Hi I downloaded the OVR lip sync SDK and I've been having a difficult time getting the live capture Demo to work. I'm able to get audio to record through my mic but nothing happens to the Demo skeletal mesh I spent all day looking at other peoples tutorials for getting OVR lip sync to work and I can't get it to work. So far I've tried using different engine versions, deleting the "default devices" line in visual studio, and fixing the references too, I can't seem to find other ways to get the live capture working, and most of the tutorials online are only about the text to speech aspect of the plugin. From what I understand it seems there is an issue with a line the plugin OVRLipSyncLiveActorComponent.cpp line 35 DEFAULT_DEVICE_NAME TEXT("Default Device") and I can't figure out how to fix it. If someone could help me out it would be greatly appreciated I'm pretty lost at this point. 

Also I'm mainly using UE ver.26 but I've tried ver. 27 as well.

 

Thank you.

8 REPLIES 8

L0B0mau
Level 2

You need to change this line to #define DEFAULT_DEVICE_NAME TEXT("") and it will work 🙂

Thank you for the reply I tried that and built the solution and unfortunately it still wasn’t working but it did work when I switched mics and tried using the mic on my oculus quest headset I’m assuming there’s a check for an android device before it allows the lipsync to start. Were you able to get it to work with a non android device mic? 
thanks agean for your help

LoboRobo1337
Level 2

For me it worked right away with my pc mic. There was none other attached. I guess it takes the mic defined as standard mic in the OS audio settings. Have you tried this already?

Thank you I did try setting my Pc mic as default in my sound settings on my Pc but that didn’t work either. maybe it was just an issue with that specific mic it was a wireless ear bod, beats. The beats mic was working in unreal engine but just not with the OVR lipsync live capture bp for what ever reason. You make a good point with no other mic being attached. I my oculus was attached with link during my testing but it was not set as default device. I’ll try testing it without oculus link attached next time and see.

 

thank you,

L0B0mau
Level 2

Did it work out for you?
You could also try writing "" or your microsoft mic name instead of the variable in this line:
VoiceCapture = FVoiceModule::Get().CreateVoiceCapture(DEFAULT_DEVICE_NAME, SampleRate, 1);

Here is the documentation for this unreal function:
https://docs.unrealengine.com/4.27/en-US/API/Runtime/Voice/FVoiceModule/CreateVoiceCapture/

DeviceName

name of device to capture audio data with, empty for default device

Sorry for the super duper late reply I couldn’t get it to work with out an oculus quest mic and ended up moving on with other parts of the project I’ll let you know if I get it working on my end.

L0B0mau
Level 2

Ok thanks for the info.
For me it also only works with one microphone, regardles what my windows settings are.
Also specifying any other microphone name for the CreateVoiceCapture did not work.

Seems like an unreal bug 😕

L0B0mau
Level 2

In the project Settings search for "Audio" and there is a section for Android where you can enable Permissions to record Audio. This might help you.