cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus plugin from 4.26 Oculus branch no longer working properly.

CarpetFace
Level 4

EDIT2: I got this new dev machine after taking an extended vacation (8 weeks or so).  Turns out, these problems are also showing on my old dev machine as well.  Is there some breaking change with the Oculus runtime and the older Oculus UE4 branches?  

EDIT: Oculus sample projects are working fine on Windows 11.  This must be something specific to my project that I am overlooking.  

 

I recently got a new dev machine for myself, and I got it with Windows 11.  I'm struggling to get my UE4 project up and running and I'm worried that the problem is specific to Windows 11.

 

Is anyone using Windows 11 and is able to do VR Preview to an Oculus Link connected headset?  If I can get a single person to say they have successfully done this, then I will stick to trying to make this work.  (I don't want to have to wipe this machine to Windows 10 if I can help it).

 

Compared to my old Win10 dev box that has everything working: I've sync'd my git to the same exact point in the Oculus UE4 branch (4.26) and here are the differences I can note:

Launching the editor while Oculus Link is active no longer automatically launches Steam VR.  

Doing VR Preview in the editor results in corrupting the entire process somewhere in the middle of a call to UOculusFunctionLibrary::GetPlayAreaTransform() (the callstack turns to nameless symbol-less garbage, clearing undefined behavior happened).  

I thought it might have been because I had set Oculus to be the OpenXR Runtime, but changed that back to SteamVR, but still SteamVR doesn't auto launch.  If I manually launch it before starting the editor, the first time I tried this I was able to get past the GetPlayAreaTransform call, but there were other controller related problematic symptoms such as button touches stopping and starting speradically, and didn't take long until the controller disappeared from the character and hit a check of mine.  While that was bad, at least it got past the GetPlayAreaTransform call a couple of times, but I haven't had that amount of success since.  This got me wondering if this is a Windows 11 issue and started searching for Windows 11 related topics, and what I found was not encouraging.  

0 REPLIES 0