cancel
Showing results for 
Search instead for 
Did you mean: 

[OculusGo] How to remove Google Mobile Services? (UE4.18)

DEFICIT_Games
Level 3
Hi there.

I'm trying to port a GearVR Game to OculusGo. It's not a big deal, because it's nearly the same.
But there is one restriction - Google Mobile Services have to be disabled .

Compatibilty Test:
"The package uses Google Mobile Services, which is not supported on this device."

Google Play Support is set to false and all Google PlugIns are disabled., but that doesn't help.
Does anybody know how to fix it?

Thanks in advance,

Andi, DEFICIT Games
1 ACCEPTED SOLUTION

Accepted Solutions

DEFICIT_Games
Level 3
@imperativity

... Ok. It's seems to be solved. I don't know how, but we fixed it.

View solution in original post

14 REPLIES 14

Heaney-555
Level 7
What engine are you using?

DEFICIT_Games
Level 3
Sorry, I forgot to mention. It's Unreal Engine 4.18.3

Anonymous
Not applicable
As far as I know it's just deactivating the Online Subsystem Google & GooglePlay plugins.
This is a bit of a bummer for me since it was required for Google Analytics plugin I was using to for in game event analytics 😞

DEFICIT_Games
Level 3


As far as I know it's just deactivating the Online Subsystem Google & GooglePlay plugins.
This is a bit of a bummer for me since it was required for Google Analytics plugin I was using to for in game event analytics 😞




I already did it. Oculus Go option is still deactivated because of Google Mobile Services.

Anonymous
Not applicable


@DeficitGames

You have GooglePlayStoreHelper
in your apk package:



           
this.a.d.a("[GooglePlayStoreHelper] -
ServiceConnection::onServiceConnected");



           
this.a.b = Stub.asInterface(iBinder);



           
this.a.c = true;



           
try {



               
this.a.d.a("Checking for in-app billing 3 support.");



               
int isBillingSupported = this.a.b.isBillingSupported(3,
this.a.e.getPackageName(), IabHelper.ITEM_TYPE_INAPP);



               
if (isBillingSupported != 0) {



                   
this.a.d.a("In-app billing version 3 NOT supported for " +
this.a.e.getPackageName() + " error " + isBillingSupported);



               
} else {



                   
this.a.d.a("In-app billing version 3 supported for " +
this.a.e.getPackageName());



               
}



           
} catch (RemoteException e) {



       
        e.printStackTrace();



           
}



 



This was likely added when you built your app with UE4. 


Can you check if the following options in UE4 are set correctly?

sd3p216rjtnq.png




Hi @imperativity  I have the same problem and can confirm my android settings looks exactly the same as your screenshot. It appears UE4 adds this regardless of what you have set there. Pretty annoying as it means I cannot upload my Go build 😞 Is there a workaround else could this requirement be removed from the Oculus dashboard until the UE4 integration has been fixed? It does not appear to have any negative impact on the Go device itself or?

Anonymous
Not applicable


@aussieburgerVR

Can you try the following and let me know if this fixes your issue?




  1. Update and
    remove “Gear VR” from their app description below
    1. NEW: Optional GearVR
      Controller support!!
  2. The new name for mobile
    controller is “3DOF Controller”
  3. Try to upload
    again


Hi @imperativity it appears to be working now thanks! I updated our app description removing the GearVR reference. I did not need to do step 3 though as the build was already uploaded and the Google Services error message was gone.
How long will it take for the review process to complete? Hopefully before the Go launch! 😉

Anonymous
Not applicable


@aussieburgerVR

I'm glad to hear your problem has been solved!

In regards to review time, there is no exact time-frame to quote for review length. If you ever want an update to where your application is in regards to review, please reach out to the store submissions team at submissions@oculus.com


@imperativity I spoke too early. I just got feedback from Oculus with the following error:

uqtpzrojvt1r.png
still complains about the Google Mobile Services issue. Please advise, is this just a general info warning or a blocker for making the app appear in the device store?

PS: game with 1.25 runs fine on the device regardless of this.
PSS: game with 1.24 has issues (unrelated to this) and I see that is for some reason recommended for the device launch. Or is that for Unity only and not Unreal?

Anonymous
Not applicable


@aussieburgerVR

I looked into this internally and we can't see a new build past April 23rd. You will need to upload another build for this to resolve itself on your dash.


@imperativity I uploaded another build even though it's exactly the same (just a new version number) and I didn't see any issues on dash anymore.
Version 1.0.20 is now uploaded to the store however it still does not appear in the Oculus Go companion app so I assume it's still not actually working. Do I also need to trigger a meta data review by adding space character in the description or something?

DEFICIT_Games
Level 3
I still found no way to fix it, too. But when I upload a build form a new game, which isn't released yet, the oculus go option is available and not grayed out.