cancel
Showing results for 
Search instead for 
Did you mean: 

Upgraded from 4.24 to 4.27.1 and can't package

JoeWilcoxWisE
Level 2

I have just recently upgraded from 4.24 to 4.27.1 (both from the Oculus branch via GIT).  I can develop and launch to a Quest 2 just fine, but when I package, it consistently fails. 

 

LogInit: Display: LogOnline: Error: Oculus: FOnlineSubsystemOculus::InitWithWindowsPlatform: ovr_PlatformInitializeWindows error: -5

 

5 = Unable to Verify. 

 

I do have my OculusAppId filled out in DefaultEgnine.ini and worked 100% on 4.24.  Should not being able to verify kill the packaging process?  I'm wondering if something else is going wrong (the actual package log isn't much more help).

6 REPLIES 6

mdcwhitaker
Level 2

I have been struggling with 4.27.1 also. Did you manage to compile 4.27.1 without errors? I and several others haven't been able to do so, and could be causing issues.

JoeWilcoxWisE
Level 2

This wasn't a compiling issue.  To be honest I have no idea what was causing it.  I fixed it by removing the Oculus OnlineSubsystem, packaging, the readding it.  Suddenly it all worked again.  Go figure.

 

If you are just upgrading to 4.27.1, there are problems with the latest Android SDK Build-Tools.  You'll need to disable 32.0.0 and 31.0.0 since they renamed some batch files (or manually copy the batch files).  What compiling issue are you having.  The main code compiled just fine.

Glad you managed to solve your problem, must have been super annoying that this was the solution! At least it is now working for you though. I'm on Android sdk 10.0, API 29. I may go to 30 to see if that helps but I am not sure that's the issue.

The file: UnrealFileServer.cpp fails to compile. The thread here: https://answers.unrealengine.com/questions/1034296/building-ue-427-fails-due-to-missing-physx-header... goes through various fixes but none of that has worked for me. Headlesschaos compiles fine for me. I have deleted entire engine and rebuilt from scratch, but no luck. Annoyingly I can't rebuild using VS 2017 as it states incompatibility; presumably when the VS files are generated it's using VS 2019 and thus can't use 2017. Not sure if there's away to force use of VS 2017. Am looking at that option now just to see if that solves it.

Have you tried upgrading to VS 2019?  4.25+ really wants 2019.  I suspect it's a missing SDK or something that not installed in to VS 2017 like the solution to the answers thread said. But the free 2019 community edition works fine.

mdcwhitaker
Level 2

I have indeed. The compile errors are cropping up when using VS 2019 and Windows SDK 10.0.18362. If I use an older SDK or a newer SDK i get even more compile errors. Looking at the UEBuildWindows.cs file, it looks like it wants Windows SDK 10.0.18362 by default. 4.26.x all built fine with VS 2019. Very frustrating indeed. Will continue to troubleshoot.

Anonymous
Not applicable

Fwiw I am using latest 4.27 Oculus from git.  I can package successfully most of the time.  Periodically, I will get an apk that only launches to the "3 dots".  When this happens, I typically launch directly to device (which works consistently)  then repackage.  That package seems to work.

 

(Used both vs 2019 and vs 2022)

Also able to package windows client and linux server builds.  (Linux server requires disabling Oculus plugin).

Also worth mentioning I do get a crash periodically when launching due to an issue saving a child blueprint.  I have a thread on the forum detailing this annoying issue.