Oculus Quest 2 and Quest
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

connection problem

Hello i have problem with cable configuration since i reinstaled my win10 a few days ago (so i needed to reinstal whole oculu s shiet) and i cant pass connection when i plug usb-c to headset and launch oculus its keep closing and opening like on the ...

Screenshot_1.png Screenshot_2.png
Mkmiaz8 by Level 2
  • 39 Views
  • 1 replies
  • 0 kudos

Air Link Wont Work!

Ok, so I'm trying to get into air link right? But whenever i press launch, there are 3 loading dots. and when the loading is over,it takes me back to the oculus home screen. And, I get a message when trying to launch...

Screenshot 2021-05-03 190453.png

Resolved! USB 3.0 recognized as USB 2.0

I've seen a lot of people struggle with this. I just got the Oculus Quest 2, and i was hoping i could play pc vr games for the first time. But when I started the setup process, it told me that a USB 3.0 is recommended even though its plugged into my ...

Crashing to Home

I recently bought a quest 2, and when using the Oculus link it will crash instantly when loading any Steam game. I've tried multiple Oculus titles and all seem to work fine, but any steam games will kick me straight out of the link. I have the offici...

Failed to connect to servers on Echo VR

I’ve completed the tutorial, but never played Echo VR because I can’t join a group lobby. I get Failed to connect to server over and over when the servers are up and running. I’ve tried all three rooms, not sure what else to do. Is it a router, firew...

Labels