Support
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! Quest 2 - Software Update Required

I have had this issue trying to pair both of my Quest 2's for the last 4 days. When you click 'try again' it just loops back to this screen.I have tried reinstalling the app (including updating the app), using an IOS phone and using an Android phone,...

img_8913.png
G_CDoc by Level 2
  • 2288 Views
  • 34 replies
  • 8 kudos

Resolved! No access to Facebook account

My Facebook account that was linked to my oculus quest 2 was banned for no reason, I don’t even use Facebook and I only made it for my vr. Since my Facebook account was banned so is my oculus so now I can’t play anything and I can’t even sign in or d...

Known Issue - Headset logged out and missing app library

Hi everyone, the team is working on an issue now based on some reports that users are getting logged out of their headset or aren't seeing their purchased apps. In some of these cases, you might not be able to log back in. The team is working to get ...

Resolved! How to pair quest 2 to multiple phones

I own a Quest 2. I made an account, paired my phone with the code, and it was set. I made another account for a family member, but when they download the app and try to pair their phone on their account, the code does not show up. Any ideas?

Slosshy by Level 2
  • 20771 Views
  • 17 replies
  • 4 kudos

Horizon Worlds Issue (Coming Soon) US 18+

I've had this headset set up and have been using it for over a year.I still cant download Horizon Worlds on my PC. It just says "Coming Soon".NO I am not using a VPN or Proxy.YES I am 18+YES I have my facebook linkedYES I have it already on my headse...

Oculus Quest 2 - Controller Keybinds

Hello Friends, I am new here and am interested in getting the Oculus Quest 2, but I have a concern about the controllers. A couple of friends just recently bought the Oculus 2 and I got to try it out and loved it! So, my concern is about the keybindi...

my right hand quest 2 controller wont track

only my left one works properly the right controller vibrates and I can use the oculus button on it but that is all, it does not track either so I can not move it around.I have tried.restart.factory reset.cleaning it.replacing batteries.recharging th...

Explorer keeps opening

So i have my quest2 open for a hour or more way past start up and when i start playing a game usually happens in vrchat after a while it will black screen and open up explorer how do i disable it or just get it to stop doing that?

Using Meta Quest 2 for 20 students

I just purchased 20 headsets for my college. I would like to use them in my chemistry labs. Can anyone help me learn how to get 20 headsets up and running?

Referral questions?

So I recently bought a Quest 2 (about maybe 6 days ago, just got it yesterday) because my friend asked me to get one so we can play VR Chat together. I didn't use the referral link because I didn't know that was a thing and he didn't know it was a th...

Files dont appear on unknown sources

When I try to download the files over and over again and it doesnt work I have unknown sources on but when I download the files they dont go on to unknown sources

My Oculus Rift S has stopped working

For the past month or so my oculus rift s has slowly decayed in quality. now every time I launch an application, it works fine for about 1-4 minutes before freezing my entire computer, shutting down and giving me a message that my DisplayPort has dis...

saving game progress and settings to pc

my quest 2 is acting up and im gonna factory reset it. is there a way to save my game progress to my PC, and potentially customized settings (ie. Home Environment and other settings), so my quest feels the same even after reset? I know how to get to ...

Airlink Max Connections Help

Hello all, I am trying to find out if there is a limit to how many airlink connections you can have at once on a network. I have been testing out the connections on my new network. We have 1gb line with Unifi UDM Pro and 10gb UDM switch and a WiFi 6 ...

SkyRL by Level 3
  • 204 Views
  • 3 replies
  • 0 kudos

HELP

I deleted the Rift s USB hub in the control panel, and now nothing has been working the USB never works works when I plug it in. It just tells me the USB connection is not working, is there anyway I can recover it.

BLORO66 by Level 2
  • 170 Views
  • 4 replies
  • 0 kudos

Install Queued. Issue

I earlier today tried to install a game using the oculus app on my phone to my quest 2, After I pressed install it said it was queued. After a bit of waiting and it not changing I decided to press it again and it then said, “Headset offline, this wil...

Connected to Wi-Fi but no internet. Oculus quest

Today may 20 2022 I tried to play my oculus but found that my internet wasn’t working. I looked at it and it said connected but no internet I tried to turn Wi-Fi off and on. Didn’t work, tried to forget Wi-Fi and reconnect didn’t work I restarted rou...

Resolved! My account won’t load.

 “Unable to load. Please try again later.“ is what my oculus says when ever I go to my account. This has happened before and I factory reset and it fixed it. I month or two later it’s happening again. I don’t wanna factory reset and lose my progress ...

7E7F4538-E6F1-4B9A-B012-1BFFB692FB17.jpeg

Optimize my Headset?

For awhile now I've struggled with games such as B&S although my favorite I find it irritating just how laggy it gets in a short amount of time, to the point where it becomes unbearable to even play. Awhile back I'm not sure how I resolved it but I w...

Turning on the Quest 2 completely stalls my network

averaging 50Mbps on speedtests, but as soon as the Quest 2 is booted up, it plummets to 100Kbps. I've been looking for solutions on google but all I've found were other WiFi issues and forum posts without any solution. Any idea what I could do to fix...

Resolved! The main menu screen is all black

EDIT: I posted this as an issue in the forums > here <. Hi. This is the second time that happens to me.When I turned on my headset today the main menu was all black. Only I could see the controllers and hear the Oculus menu button when I pressed the ...

SoyNexZ by Level 3
  • 363 Views
  • 2 replies
  • 0 kudos

PCVR question for onward

What is the best way to play my VR game: onward Gamepc > airlink > oculus home > open pc > open steam > play onward and choose launch onward in steam VR mode;Gamepc > airlink > oculus home > open pc > open steam > play onward and choose launch onward...

Left controller not working

so the last time i played was 2 weeks ago and every thing was fine but today when i went to play BeatSaber my left controller started disconnecting after the second song. Since i store my quest and controller i dont know why it's doing that i've trie...

Volt720 by Level 2
  • 201 Views
  • 2 replies
  • 1 kudos

Oculus MRC blurry and Pixelated

I checked my internet speeds and it's very fast. I'm using OBS and I tried changing the bitrate of my video capture but it still looked blurry pixelated and terribe. Every youtube video I watched said the same thing but it didn't help. Is there any o...

lilbunn by Level 2
  • 104 Views
  • 0 replies
  • 0 kudos

Help my oculus quest 2

hello, I get a yellow dot on the left lens where I'm looking, I still don't know what happened to it, it suddenly came out, could you help me, what can I do?    

E4CDD600-93C6-4071-BCD4-D3AF25C1CA68.jpeg 0C69833D-0371-4FA3-938D-05F360C780B0.jpeg 9C9B2243-CA56-4513-9A69-57812C1248E6.jpeg 5C2677FE-CA4B-41EE-A2A4-692A645D9512.jpeg

Cant buy games

I haven’t been able to buy games for months, I’ve tried almost everything besides, making a new PayPal, getting a new card, or switching banks. Everything else I’ve tried and this is so irritating. Every time I put a support ticket in I feel like the...

Resolved! Can't connect using oculus link cable.

When I'm in the pc app, and connect my Oculus quest 2 with the link cable, the app closes and then opens again, and then closes again and then opens again. It keeps doing this and because of it, I cannot connect my Oculus to my pc using the cable. I ...

Labels