klatusatori
Level 2
since 3 weeks ago
3 weeks ago

User Statistics

  • 1 Posts
  • 0 Solutions
  • 0 Kudos given
  • 0 Kudos received

User Activity

I'm trying to launch elite dangerous but I am getting the following message: "UPDATE REQUIRED"The game requires an update before you can run it. You can check for updates within Oculus Home by selecting the 'updates' option in your library."There may...