New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Help! Gear VR software will not install on Galaxy S6



  • azirb9azirb9 Posts: 1
    Device:  Galaxy S6 (SM-G920P)

    I had the same problem as those with the Sprint version of the Galaxy S6.  Occulus would not allow me to go beyond the system activities update.

    I tried the following link to Occulus support stie and did what was advised.  My galaxy S6 worked just fine.   You have to enable the Facebook app manager and installer in order for the software to be updated.  Hope this helps those still having trouble.
  • BengaleBengale Posts: 2
    Finally got into the process and sign into oculus app
    Hi guys,
    I finally succeeded in getting the download process working:
    - log the samsung app output with logcat via adb 
    - click on install button of the Gear Vr configuration wizzard
    - catch the called urls on logcat and copy/paste them on your browser to download the APKs 
    ( for me : prePost_20160128024220687.apk

    - install them in the order the urls were called ( adb install -r prePost_20160128024344077.apk )
    - on the device, stop the download using the cross
    - click the install button again
    The download should now be successful.
  • hzoli4hzoli4 Posts: 1
    Chubbyluve wrote:
    The fix is in the Gear VR help section under update issues.
    You have to enable the two applications which maybe disabled for some reason.

    com.facebook.appmanager (App Manager)
    com.facebook.system (Installer)

    I located them in applications and viewed the system applications.

    I am using a Galaxy s7 on Sprint. Once I did this I was able to get the update to complete and enjoy the VR experience.

    Hey there, I've been trying to get this to work on my Wife's S6, initially she didn't have com.facebook.appmanager or .system listed in the Manage Applications. I went ahead and did the system update which brought her to Android 6.0 (Sprint btw). She now has the .appmanager which defaulted to Disabled. I've enabled that but I honestly don't see the com.facebook.system anywhere. Any idea what else I can do?

    I've done the initial install of Oculus stuff, but now it wants me to update the Oculus System Services or something, and that update never goes thru, it downloads to like 80 percent and then the notification disappears. I don't have any other packages blocked or any special package blocker apps.

    EDIT: Figured it out, I had to click "More" -> "Show system apps", found it disabled. Enabled it and everything is working!
     thx :)
  • Noodlesv2Noodlesv2 Posts: 1
    I recently purchased the VR Gear device only to find myself facing the same issue. I know this forum post is dated, but I found it while attempting to find a solution to my issue and thought it would be nice to post in case anyone else is having the same issue. Since the device is run through facebook, you MUST go through your settings to make sure facebook permissions are enabled. Directions are as follows:

    How do I turn on App Manager and Installer?
    To turn on the App Manager and Installer, tap on the "Settings" application, then "Applications" and finally "Application manager". Make sure you have chosen the "All" category and find the following applications: 
    • com.facebook.appmanager (App Manager)
    • com.facebook.system (Installer)
    Tap into each and make sure they are enabled. 

    Unable to find com.facebook.system

    If you are on Android OS 6.0 (Marshmallow), com.facebook.system may not be visible. Please try the following steps:
    1. Navigate to Settings
    2. Tap on Application Manager
    3. Tap the More menu in the upper right corner
    4. Tap Show System Apps
    5. This will make com.facebook.system visible and allow you to enable it.
    The App Manager and the Installer must be enabled before Gear VR apps can be installed and updated on your mobile phone.

  • Suggesting anyone drop their carrier because the software their company provides is provided broken has to be the most ridiculous thing I've read. Seeing that posted when unable to update my software on the Note 7 has not made me reconsider my carrier. Instead, I have packed up the Gear VR.
  • Gear VR and Oculus is a piece of fucking crap does not work properly and Oculus and facefuck dont give two shits, waiting for Sony VR so can put this piece of shit in the bin
  • I dont see "show System apps" in more...
  • aliothman99aliothman99 Posts: 1
    I have galaxy S7edge and oculus app was working at the first . But recently it says your oculus software needs to be updated to the most recent version.  And when i update it it still says your oculus software needs to be updated to the most recent version.  I cant use my vr becouse of that . Can anyone help me???
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!