New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

[SOLVED] Installer fails OVRlibrarian.exe with exit code 7

AC81787AC81787 Posts: 6
edited April 2016 in Support

Folks, I once successfully installed the oculus home.  However, after reinstalled it for troubleshooting the software download problem, I encountered the following issue (as per the setup log)

Process C:\Program Files (x86)\Oculus\Support\oculus-librarian\OVRLibrarian.exe exited with code 7 (failure).

Anybody know the cause of exit code 7 for the above ?

FYI, I uninstalled Antivirus software and cleaned the registry.  No permission issue.  Running on Windows 8.1 with latest NVidia driver.


Thanks in advance.

Comments

  • PopopinselPopopinsel Posts: 179
    Art3mis
    The installer has to be run from a folder on drive c:. Also %temp% has to be on the c: drive.
  • AC81787AC81787 Posts: 6
    Thanks for the reply. Yes. Both on drive C. Is it the meaning of exit code 7 ? If so, then strange...
  • PopopinselPopopinsel Posts: 179
    Art3mis
    Did you uninstall all Oculus software and rebooted before trying again?

    Also, just to double check, can you please post the complete file path of your OculusSetup.exe (hold shift key and right click on the file and select "Copy as Path", then paste it here using STRG + V) and to which directory %TEMP% resolves on your PC?
  • AC81787AC81787 Posts: 6

    Thanks Popopinsel, much appreciated. 

    The path is "C:\OculusSetup.exe"

    How do I know which directory %TEMP% resolves ??  If system drive is C, then %TEMP% is C too ?  Can I amend %TEMP% ?

  • AC81787AC81787 Posts: 6
    OK, just find that %TEMP% is set to be "C:\Windows\TEMP".  The problem persists..... :-(
  • AC81787AC81787 Posts: 6
    Resolved, after reinstalling Windows with minimal set of drivers.  Very sad, and not sure if any other new problem when I start to reinstall applications.....  i'd say the Oculus home app is not ready (that's why it's called BETA ?)
  • jessomejessome Posts: 4
    "Re-install Windows" isn't really an acceptable solution. Has anyone else experienced this with an alternative solution? 
  • teri1337teri1337 Posts: 1
    I am experiencing the same issue ("OVRLibrarian.exe exited with code 7 (failure)."). Oculus Support suggested my under-spec video card was the issue, so I replaced it with a GIGABYTE G1 GAMING GEFORCE GTX 970, but to no avail. I've submitted an update to support and will post an answer here if they come up with a solution that *doesn't* involve re-installing windows...
  • highfreqhighfreq Posts: 1
    I'm seeing the same problem on a new PC with windows 10 fully updated, gtx 970 with updated drivers. Very annoying that I have to wait for it to re-download everything each time before I find out it is another failure. 
  • jessomejessome Posts: 4
    @teri1337 @highfreq Did either of you have to uninstall runtime 0.8 before running the 1.3 installer? I know the installer *thinks* the old driver is gone, if we made it this far in the installer, but maybe there's something lingering?  
  • Same code 7 problem on a brand new "oculus ready" Asus. Is this marked "solved" because OP re-installed Windows? Someone at Oculus can look up code 7.

    Anybody find a real fix?
  • jessomejessome Posts: 4
    I solved mine! I don't know what when wrong the first time I tried it, but, with the 1.3.2 installer I fully uninstalled McAfee Antivirus (including the pesky 'managed' Agent) and the installer got past error 7!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories