New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

"Check Your Setup" CV1 External Camera "Searching Windows Update..."

InfiniteInfinite Posts: 128
Hi. I cannot install the CV1. The Oculus software is stuck in a loop on "Check Your Setup". I cannot get out of this mode to check any settings or hardware statuses. I'm certain the external tracking camera is also not installed correctly.

I can also see in Device Manager CV1 External Camera a yellow triangle with the exclamation mark. When I force Uninstal I get CV1 External Camera "Searching Windows Update..." Windows is stuck trying to get the driver. It eventually fails with No driver found. But it doesn't matter as I cannot do anything else because Oculus is stuck at "Check Your Setup" page.

Where can I download the CV1 External Camera driver?

In the past I have installed a multiple DK1's, multiple DK2's, GearVR, multiple VIVE's and VIVE Pre. The CV1 so far has been a nightmare to get working. I haven't seen many others with this bug.

What causes this "Check Your Setup" software loop. How do I get out of it? There is no back button or settings button. No icon tray to back end settings. I've I'm struggling with this as a developer, how the hell are consumers going to manage?

Why can't Windows find the driver?

I have updated Win7 to the latest patches, I've downloaded the latest Fresco USB3 drivers. I've tried USB2 and USB3. I've tried to uninstall Oculus and re-install only to be greeted once again with "Check Your Setup"

Can anyone help?

http://www.ir-ltd.net/uploads/checkyoursetup.jpg

_________________________________________________
I N F I N I T E

www.ir-ltd.net
«1

Comments

  • InfiniteInfinite Posts: 128
    Even if the external camera and headset is unplugged, guess what.. "Check Your Setup"!!!
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    Any help on this would be most appreciated. How do I get out of the "Check Your Setup" loop.  A ticket has also been filed with no response.

    Thank you.

    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    To pass that step, you have to look inside the headset. Is there not anything showing up on the screen?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • InfiniteInfinite Posts: 128
    edited April 2016
    Thanks for the reply.

    Yes. If I put the headset on (bare in mind there is no light on the CV1 tracking camera) It says "Set Your View in VR" etc etc If I press the button on the remote control it then says "Remove your headset, your sensor isn't tilted the right way" Etc Ad infinitum. TO clarify the CV1 external camera is pointed right at the headset when on at the correct distance but I am certain it's not installed correctly.

    On the PC... "Check your Setup". It is stuck in this nasty loop. There is no way I can get access to any settings. Why am I locked out?

    If the CV1 external camera is unplugged and there is no headset attached... "Check your Setup" when I run Oculus.exe.

    How can I find the drivers for the CV1 External Camera? Windows cannot get them.

    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    Is there someway I can completely remove the Oculus install and start from scratch? i.e. re-configure everything step by step? Perhaps removing registry settings?

    If I uninstall Oculus and reinstall Oculus. When I run Oculus.exe I go straight back to "Check Your Setup"
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    The sensor drivers are installed as part of the setup. I would try disabling any anti-virus on your computer first. Another thing to try is to switch USB ports (try on a USB 2.0 port maybe). I've also attached what I think is the latest sensor driver. Can you try running that installer and see if it helps at all?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • InfiniteInfinite Posts: 128
    Thanks. I've disabled anti virus. I've tried USB2.0. I just installed the OculusRiftSensorDriver.msi. It doesn't seem to add any cab files or physical driver files anywhere? Device Manager needs to point to the drivers. Windows tries to search online with no joy.

    This still doesn't explain the bug with "Check Your Setup" Why is there no settings button, icon or back button? Why is there no tray icon like on the DK2? I'm totally locked out of the Oculus setup. Why has it been designed this way?

    Is there anyway I can remove Oculus totally from my PC and retry the setup procedure? Anyway to get access to that process again?
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    Despite the "Check Your Setup" issue. Drivers are still no go http://www.ir-ltd.net/uploads/loop.jpg

    Eventually it will say failed to install drivers..
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    Even after OculusRiftSensorDriver.msi - http://www.ir-ltd.net/uploads/nodriver.jpg

    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    edited April 2016
    In comparison the VIVE Pre was a breeze to setup and that's saying something.. Perhaps I'm just unlucky here but if I've hit these snags, consumers certainly will. I'm pretty PC savvy but this has me stumped. The Oculus software lockout "Check Your Setup" and no settings controls is a baffling design choice to me. It must be a bug? As there is no way to exit this process, either on the PC or in the RIft.

    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • MrKaktusMrKaktus Posts: 81
    Hiro Protagonist
    I had exactly the same issue. "Check Your Setup" step during installer was invented by some idiot, on the video it shows that I'm supposed to just move Oculus in front of the sensor. There is completly no information that I need to put it on my head (so that proximity sensor will detect that and turn on tracking sensor).

    As a result I tried it several times. Finally I decided that probably my sensor is broken, I read in the internet that I could try "resetting the sensor from withing Oculus app". So I decided to Skip that step completly and just skip rest of the setup to the end, then reset sensor and try again.

    Then it came out that I cant. Setup goes to the point when rest of it should be done in HMD. Of course nothing was displayed in HMD even when I was putting it on and waiting (hoping that sensor will turn on). And that's how I've stuck in Installer Limbo. Back arrow to move back by one step in the Setup is grayed out so I cannot move back. I cannot cancel. I cannot do anything.

    Then I decided that I will uninstall whole damn thing and try from scratch. And now the great finale !! 
    After uninstalling oculus completly, unpluging all devices, and restarting my PC several times, Oculus setup is no longer even installing !!! It Downloads 844MB and then says it cannot continue and that I should restart PC.
    Infinite Limbo.

    Who the hell designed this thing ?????
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    edited April 2016
    Can you open a File Explorer window and paste this in the URL field:
    %LOCALAPPDATA%\Oculus\
    Then look for "OculusSetup.log" and sent that to me.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • MrKaktusMrKaktus Posts: 81
    Hiro Protagonist
    Ok, so I've used RegEdit (by the way first time since Windows 98), to came to conclusion that it's not Registry issue. I found oculussetup.log and info that Visual Studio Redistributable cannot install returning error 16??. So whole Installation fails BECAUSE I ALREADY HAVE VS2015 REDISTS INSTALLED ! Thats awesome. I've uninstalled them manually and run setup again.

    Oh happy me! Setup went through, and after installing it from scratch, guess where I was placed ? 
    Again in Limbo loop of "Adjust Your Focus" step. 

    My question is how to RESET Headset Setup ??
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    edited April 2016
    Can you all please send me the log files from your computer? You'll just have to run "OculusLogGatherer.exe" inside "C:\Program Files (x86)\Oculus\Support\oculus-diagnostics" and send me the zip file. Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • InfiniteInfinite Posts: 128
    edited April 2016
    @MrKaktus It might be worth starting a another thread? Your issues sounds different.

    @Cybereality: Thank you for looking into this. OculusSetup.exe should really have a "Restart setup" procedure. There is no way to go back through the setup process to double check everything was installed correctly. Or perhaps a Settings.exe? So we can at least get access to see what certain devices are doing. Which I was able to do before this "Check Your Setup" loop.

    Please pass on my concerns about no low level access to Oculus about device settings, via an Icon Tray. It's very concerning. I've sent you a PM with my diagnostics file.




    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Can you try these steps?

    1. Stop the Oculus service (using services.msc)
    2. Delete AppData\Roaming\Oculus (in C:\Users\YourName)
    3. Restart the Oculus service, which should also relaunch the Oculus app

    You should be prompted to sign in again and should no longer be stuck on the VR sensor setup step. However, if the sensor driver is still not installed properly, you may face other issues at this point.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • InfiniteInfinite Posts: 128
    Thank you very much. That's a real nasty work around but it got me back to the setup procedure.

    It all points back to Windows 7 not being able to find the drivers to the sensor. Even using that driver file you sent me. I cannot get past this stage.

    http://www.ir-ltd.net/uploads/sensor.jpg

    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    If try and do a driver update, search windows etc It just gets stuck in "Searching online for software..." Eventually Failed to install drivers..
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    So, can you try on a different computer (maybe one with Windows 8 or 10)? I'm thinking that it may be a hardware issue, either incompatibility with your computer or a defective sensor. I don't think there should be any hassle in installing the driver.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • InfiniteInfinite Posts: 128
    At the moment I cannot try on another computer. I'm not sure when I will be able to do that. Shame it wont install here. All other VR headsets installed without problem.

    I will look into buying a brand new VR ready PC, it wont be cheap :) I need to move to Windows 10 anyway. Hopefully this thread might be useful to others.

    I will report back if I can get a new PC in place.

    Thanks for your help Cybereality.
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    Cybereality is there no way to get access to the actual CV1 External Camera driver files so I can point Windows to them directly? That might help.
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Can you try running "oculus-driver.exe" in "C:\Program Files (x86)\Oculus\Support\oculus-drivers"?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • InfiniteInfinite Posts: 128
    edited April 2016
    Thanks, that certainly helped force the drivers into Windows7. The sensor was seemingly then installed. However. I go through the setup procedure. All seems fine on "Connect Your Rift Headset and Oculus Sensor". Then a few pages down the line "Check Sensor Setup" "Your sensor isn't working properly...

    http://www.ir-ltd.net/uploads/sensorfail.jpg

    I've tried various ports.

    I just got another popup from Windows

    http://www.ir-ltd.net/uploads/sensorfail02.jpg

    The CV1 is not listed in Device Manager with the yellow warning but seems it's still not installed.

    The sensor is emitting heat so it's doing something. I've tried various USB ports.

    "Connect Your Rift Headset and Oculus Sensor" tells me the Sensor USB is OK, yet Windows says it's not installed and I get "Check Sensor Setup" "Your sensor isn't working properly...

    This is a hard install.

    The driver seems to be installed

    http://www.ir-ltd.net/uploads/driver.jpg




    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Can you please provide the log files I requested (just scroll up for the instructions)? That will help me in having the engineering here try to diagnose the problem. Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • InfiniteInfinite Posts: 128
    Sure thing. I sent them to you by PM about 2 days ago :)

    Do you need another set?
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    Another set sent by PM.
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    Hi Cybereality. Did you receive the PM details?
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    Hi Cybereality. Did you receive the PM details?
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
  • InfiniteInfinite Posts: 128
    edited April 2016
    Can you please provide the log files I requested (just scroll up for the instructions)? That will help me in having the engineering here try to diagnose the problem. Thanks.
    Yes I have. Please can you confirm receipt. I am getting no where here and support (ticket) have not helped at all.
    _________________________________________________
    I N F I N I T E

    www.ir-ltd.net
«1
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories