Showing results for 
Search instead for 
Did you mean: 

Rift 1.40 Release Rolling Out Now

Community Manager
Community Manager
  • We've added a new button to the Dash belt to select and view individual Virtual Desktop panels.
  • We've improved stability and performance of Virtual Desktop. Please make sure your version of Windows 10 is up to date to take advantage of these improvements.


We’ve made performance improvements and feature updates to improve your experience while interacting with Guardian. These updates include:

  • Ability to clear your Guardian boundary history from your Guardian settings menu.
  • Opportunity to confirm your Guardian boundaries are accurate when you first put on your headset.
  • Removed the need to indicate what direction is forward when setting up Guardian.

  • Updated the design and improved performance and load times for the Oculus Store.

  • You can now collect all of your Oculus Home rewards at once with the new Collect All button. (Note: this feature is rolling out slowly to everyone within 1.40. Thanks for your patience!)

  • Fixed an issue where Touch controllers could lose tracking during fast movements with Rift.
  • Removed warning that USB drivers needed to be updated when drivers were already up to date. 

As always, if you encounter any issues with this software release, please be sure to report them using the Help Center > Provide Feedback option within the Oculus desktop software. If you have any feature requests or suggestions to make the Oculus software even better, please head over to our UserVoice page to share your feedback. Thanks for your continued help!

Level 12

Cpt_420 said:

after this patch i had 3 right hand controllers usb yellow again and  warning saying no headset connected so i boxed it up and sent it back for a  refund after spending £1200  on a rig  yeah yeah i clean installed too

I can't say I blame you. I mean, you went all out with the trouble shooting. A clean install should fix everything.
Hey, good luck with your next big spend buddy.

P.S. If you haven't really sent it back, you could try getting some help from support.............
It could be a simple thing that fixes it, and you'll forget all about your massive trouble shooting woes, if you get it going.

Come on, do a proper job.

i5 6600k - GTX1060 - 8GB RAM - Rift CV1 + 3 Sensors - 1 minor problem
Dear Oculus, If it ain't broke, don't fix it, please.

Level 4
My mic still goes off after a short time and even the Oculus Support dont find a solution, send me so many things i had to try already but nothing worked.

So seems the Rift S got a lot of problems and the support tried to tell me already that the mic problem would be no hardware issue...ok 😄 

Level 3
Ever since 1.40 update I get sensors can’t track headset error!!!! Wtf man 

Level 3
oculus support said what we not announce displayport not working issue because cause unknown.  and i waiting 2 mo. 
As far as I know, this issue began to be reported on 2019-05-24.
I hope the next update will fix the issue.

Level 3
So if anyone has eset Internet security you will need to uninstall to make rifts work! My issue was eset blocking the camera or USB activity.

Level 12

BLADE_13 said:

So if anyone has eset Internet security you will need to uninstall to make rifts work! My issue was eset blocking the camera or USB activity.

Nonsense. I use and sell ESET at my workplace and it has never ever interfered with Rift. You must have had a custom rule set. 

Level 3
I keep getting a red dot close to the rift s (in software) with a request of "Oculus Software restart required"

Level 6
Why does the Oculus force everyone to switch to the extreme 1903 version of win, which shows itself much worse in games than previous versions, for example 1607?
in 1607 last 1.40 works with issue (restarting home after removing and re-putting the helmet on the head in a few minutes)
Microsoft pays for such updates ??? (((
It would be better to add support for win 7, as it is for CV1 !!!

Level 2
hi, I have a problem since the last update, access to the virtual office has disappeared from my dashboard.

Hey there @corsair83_FR We would like to get a better understanding of what you're talking about. Can you please private message us with the version number you're currently updated to?


Please select our name to get to our profile page, or click here: Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.