cancel
Showing results for 
Search instead for 
Did you mean: 

3 dots then black screen with Oculus Quest Link

brownsea2989
Level 4
Using a cable confirmed working by others (Amazon Basics USB 3 3M) and GTX 1650, 16Gb, Ryzen 5 3550H based laptop I'm having problems launching Quest Link! Headset is recognised and passes text in Oculus Desktop software and prompt appears in headset. When I launch in the headset I get a black screen with 3 moving dots. Shortly afterwards, just a black screen with the Guardian circle on the floor.

Anyone else had this?
96 REPLIES 96

soloTK421
Level 2
I've been having a similar issue, My Pc software will enable the link and say its active though in the headset i only get a black screen. After waiting a while an error popped up saying " System Utilities Stopped Working " Anyone know a fix?

soloTK421
Level 2

Locidus said:

Whenever I plug in my link it says ''Enable oculus link'' I press enable and it just goes straight to the normal home menu, I press enable on the game bar and all that happens is the screen turns black and shows dots for two seconds and goes back to the normal oculus quest home menu. Using GeForce GTX 950M.


Check the "Link Requirements" on the Oculus Website, You may require a better cable and/or a new Graphic Card

alfie1324
Level 2
I disabled internal display in device manager just leaving gtx 1660 enabled, turned off public test in oculus home and it worked.
Then tested turning vega graphics back on did not work turned it back off.
Then turned ptc on it didnt work.
so works with those two thing deactivated just sounds like a jet engine now but it works.
I was getting choppy frame rate issues which took me 30mins to figure out i was running on battery. Plugged in the power supply and it works flawlessly now although im not sure the overall headache of spending a week on this is even worth it to buy the same games again on rift store, as for steam Half life alyx here i come.

JustBrodie
Level 2
I have a question does the Oculus charging cable work as the oculus link

FelicityC
Level 5


I have a question does the Oculus charging cable work as the oculus link




Yes, it does, now.

Not as good as a full USB3 connection, but amazingly, yes, it does.
8700k @ whatever i feel like, 2070 Super, 3200mhz 32gb memory @ CL16, 1tb wd sn750, msi z370 gaming plus, pvc pipe gun

sinan_vural_319
Level 2
If you have GeForce Experience go to the Drivers tab and click on the three dots next to Check for Updates button. Select '"Studio Driver"' instead of "Game Ready Driver".

GB-
Level 2
I'm reading quite a few people are having this problem. The thing that solved it for me was that I was using a laptop with an eGPU. The Oculus PC app was using the eGPU BUT was using the onboard graphic chip for the display on the headset. To solve this I plugged in a monitor directly to the eGPU so that the software was forced into using the correct card. 

crosscuttitan
Level 2
how to fix oculus

LayXe
Level 2
Hello, using Quest 2 and have been running into the problem that upon connecting with the oculus link (beta), I only see a black screen with my guardian boundary active around me when I approach it. 

What I attempted:
- I've disabled PTC
- reinstalled Oculus software
- factory reset my oculus multiple times
- used both an official oculus link cable and an amazon basic computer (link test shows both works fine)
- used different usb 3.0 ports
- used the support recommended 1 monitor/1 mouse/1 keyboard only connected
- updated drivers on my nvidia
- used nvidia studio drivers instead
- disabled nvidia geforce overlay
- updated windows updates
- used both "deny" and "accept" prompts on connection to the cable
- attempted to get around the blacklisted usb by getting the proper driver version of my asmedia host controller on the mobo site

What I couldn't do due to not having the available means of use or not able to do since I don't know how:
- connect my oculus directly to the gpu (I have a 1070, don't have anything like that)
- disable onboard video on device manager (I'm not sure where to even find this on device manager)

Next action items:
- get new gpu (planning on getting 3080)
- get new mobo (planning to get one that is compatible with AMD Ryzen)

If I can edit comments, then I'll edit this as I go along and find more methods to try.

PC Spec:
OS: Win 10
Intel core i7-6700k
MSI z270 SLI Plus
Gigabyte GeForce GTX 1070 8 GB GAMING Video Card

LaPump
Level 2

Spuzzum said:

If you're getting the 3 dots issue, you're supposed to disable GeForce Experience Overlay in the Nvidia settings.


Thank you for this tip. I was just about to give up! It's been a while since anyone has posted, but I figured I could share some information in case people run into this issue with the Oculus Quest 2 and gaming laptops.

I'm using an Asus ROG Zephyrus G14 with an AMD Ryzen 9 and a NVIDIA GeForce RTX 2060 and an Oculus Quest 2 for VR. After setting the headset up a few weeks ago, one of the first things I discovered is that I needed to disable the AMD Radeon(TM) Graphics display driver in the Device Manager in order to get Oculus Link (Beta at the time, but official now) working.

Surprisingly, games like Boneworks and The Forest VR still worked really well on pretty decent graphics settings except VR resolution, which I had to drop to around 80-90% for a decent frame rate. On the other hand, games like Minecraft and Star Wars Squadrons absolutely tanked, and could only successfully run with all graphics drivers enabled (so, impossible for my VR setup). This is probably because disabling integrated graphics does not 100% guarantee good performance on a gaming laptop, even when a high-performance graphics card is prioritized in NVIDIA Control Panel or Windows Graphics Settings.

So, I can't fully backtrack every change I made to get this working, since I made a ton (probably many useless ones along the way), but I would recommend the following, as other people made these changes too:
  1. Disable GeForce Experience Overlay (Spuzzum)
  2. In NVIDIA Control Panel, set pretty much every Oculus .exe application to use higher performance graphics (philneitz on Reddit forum, "You want to make Oculus Link work on your NVIDIA Optimus laptop? Read this before throwing it by the window!" Sorry, Oculus won't let me post links yet.)
  3. Similarly, set your specific game applications to use higher performance graphics NVIDIA Control Panel.
  4. Consider doing the same for Oculus and game .exe applications in Windows "Graphics Settings" within System Settings.
  5. (Didn't work for me) Use an external monitor or a dummy HDMI 
  6. Reboot your computer here and there.
This compilation of fixes also ended up boosting my maximum graphics, where I can now run 100% VR resolution on these same games with frame rates that are actually easy on the eyes.