Showing results for 
Search instead for 
Did you mean: 

Airlink on Desktop Choppy and black screen tearing.

Level 3


I have a very beefy computer I7 12700k 3070 TI 32 gb ram etc self built desktop. When i try to Airlink into the Desktop its SUPER choppy with a wifi 6 router dedicated to the headset. When I hardline into the computer, everything's fine. I have tried multiple routers including a wifi 6e router with no improvement. I have had to upgrade my motherboard to an ethernet card because something happened when I moved that caused the Ethernet to go offline. I have a gaming laptop I keep in the living room. When I setup the router to connect to that computer Airlink is perfect. I am unsure as to what the issue is. Process of elimination would say its something hardware related in my desktop, possibly needing a MOBO repair or replacement. I am looking for some sort of Quest support to see if anyones experienced this. 


Community Manager
Community Manager

Hello There! We see you're having issues with using Airlink on your PC. We don't like how that sounds. Let us dive in and see how we can fix this!


Thanks for being very clear with those details. It helps us very much. You rock! Let's start with making sure your PC is compatible.



  • VR Headset: Quest 1 and Quest 2
  • PC's minimum specs. See help center article here.  
    • Processor: Intel i3-6100 / AMD Ryzen 3 1200, FX4350 or greater
    • Graphic Card: NVIDIA GTX 1050 Ti / AMD Radeon RX 470 or greater
    • Alternative Graphic Card: NVIDIA GTX 960 4GB / AMD Radeon R9 290 or greater
    • Memory: 8GB+ RAM
    • Operating System: Windows 10+
  • Networking
    • Connect your PC to the WiFi router via Ethernet
    • WiFi Router supporting 802.11n, 11ac or 11ax protocols

Configure the PC

  • The Oculus PC app should be installed on your PC. If not, download it from
  • Make sure that the Oculus PC app build is up to date. 
    • See this help center article here to learn how. 


Please let us know if this helps!

Unfortunately, Everything in your list, is a positive check from me. Ive reinstalled the App just to be sure. As soon as i get into airlink, wirelessly its jittery, when i turn my head instead of seeing the AI environment i see a black screen tearing as if it cant keep up. I am currently operating on 1 Gigabit internet, pulling approx 850+ on wifi-6. 

Thanks for your response and the update. This is actually a good thing! 


It seems like there may be some issue with your PC. We would love to review your system and get a better view of it. Will you please gather the Oculus logs for us? We've listed the instructions below. 


1. Open the Run window (Windows key + R).
2. Enter and run: C:\Program Files\Oculus\Support\oculus-diagnostics\OculusLogGatherer.exe
 *The above link is the default directory. Bear in mind that if you installed Oculus Home to another drive you will need to update the command with the correct file path.
3. Select the checkbox next to ‘Full logs’.
4. Select "1 day" from the "Collect last" drop-down list.
5. Wait for the log collection to finish. This can take some time to complete.
6. The program will automatically generate a zip file containing your logs, which will be saved to your desktop automatically.
7. Attach the newly created zip file to your next support response.

Once completed, please reach out to Meta Store Support and open a support ticket and provide the logs along with your issue. One of our advanced troubleshooting agents will be happy to further assist you.


All the best!

I am unable to drip Zip files in this box. Is there a way i can send this to you guys directly?

I tried e-mail but it rejected it


@Buzzlghtyr I think the best way to send it to support is to create an email/chat ticket first and then try to upload it after someone responds to you.