cancel
Showing results for 
Search instead for 
Did you mean: 

All Problems for Oculus Rift S

auxiliaryxx
Level 3
Use this discussion for all problems related to the Oculus Rift S! I have found most solutions for mine which I will be sharing on here as well.
Common Problems: Tracking, Guardian, Setup, Freezing, Snow Pixels, Jittering, Plug Problems, USB 3.0 errors, Game glitches, Camera problems, Headphone static, Some games don't run, Oculus home freezes, Steam vr wants to setup, Speakers make noise, Ipd glitching on horizonal side, fov is small, no sweetspot.

I will tell you how to improve FOV, TRACKING, SWEETSPOT AND PERFORMANCE as best as I can.

Let's get started!
143 REPLIES 143

Anonymous
Not applicable
Oculus are sending out a replacement cable by request.

JDenisB
Level 3
After 6 days of use, got some problems here too... Hope these will be fix soon..
- sound crackling
- white flash
- lose tracking(left touch)
- black screen
- .......
Do i need to return my rift or waiting for update?

Fangzhou
Level 6
After two weeks of usage, I have experienced:
- HMD jittering/shaking when fast movement. This is a problem for everyone, but usually people do not move fast in VR world, so I did not see many people complaining. But if you do move fast (like dancing), you will notice this. 
- Microphone sound quality is bad. My voice sounds robotic. 
- Static Flashing every few minutes. 
- Sound cracking (twice, fixed after restart Oculus services)
- Black screen (more than five times, fixed after re-plugin USB and DP and restart computer.)
- Crash when playing games (more than five times, need restart Oculus services)
- Controller lost tracking, in the virtual environment I can see the controllers position fixed at the same place as the headset. Rotation of controller still detected, but position not tracked. Experienced twice, fixed after update to 1.39 patch. 
- Very laggy tracking. And in pass though mode, the image is static white screen flashing. This happened once when I played with window open during daytime. Restart computer and use curtain to hide the window fixed it. After that I always block the window with curtain when use Rift S. 

What I have tried:
Update win10 to 1903;
Update Oculus software to 1.39;
Update all drivers to latest version;
Make sure USB driver is from intel;
Removed all mirrors or shiny items from my room;
Use curtain to hide the window;
..

It’s take me much more effort to fix the problems than installing lighthouse or cameras for Outside-in tracking. I feel Rift S is a beta version or developer testing kit, not like a proper released device for customers. I have use Oculus device since DK2, even DK2 has less problems than Rift S. 
I am also a developer (not a VR developer though), I understand that it is almost impossible to create a bug-less system. But at least serious bugs (like the static flashing, black screen, tap test failure etc. ) should be eliminated before releasing. 

seanmacd97
Level 2
Hello all, I bought my rift S about 4 days ago,
had to buy a pcie usb 3.0 extension card because my 3.0 ports on the motherboard weren’t good enough I guess.

bought a brand new gpu and psu to power it

i have experienced a whole load of problems in 4 days.

1.games keep crashing HMD goes black, 
fixed by unplugging and restarting. I can’t play zero Caliber for more than 10 mins before this happens. No permanent fix yet

2.games crash and I get “critical error right touch controller battery low” only to find in devices another right controller has been added on top of my 2 working controllers. Fixed by replugging.restarting. And running a program I downloaded to delete the “phantom controller” only for it to happen again within an hour. Again happens allot in zero caliber title but also in other games. No permanent fix yet

3. Tracking made it impossible to aim a 2 handed weapon as tracking would freeze for a second or so while aiming. The PTS beta fixed this but gave me a tracking jitter when firing guns. Eventually reinstalling all software and firmware seems to have fixed this problem.

4. Games seem to take forever to load, sometimes don’t ever complete loading and other times it’s quick. This may be due to me not having a SSD. I’m buying a SSD soon and hoping it will fix all these problems. No fix yet

5. Can’t complete the boundaries section of steam VR as it doesn’t let me press next after walking around the room holding headset and trigger or trying the advanced clicking option. Nothing changes on screen when I press trigger. No fix yet

6. White flashing from time to time. No fix

all my power saving settings are disabled.

Please any suggestions or advice is much appreciated 
OS: windows 10
GPU: Radeon RX 580
CPU: AMD FX 8350 eight core
RAM: 16 gb 

Dreadpirateflap
Level 5
Got my rift s a few days ago, and just can't throw stuff. the right grip seems to lag meaning anytime I try and throw anything it plops to the floor. Removing the battery cover fixes it instantly, so I assume the magnets are causing issues.
Not nice to play with no battery cover on though. Not exactly comfortable.

Also having that white flash quite often as well. Submitted a ticket to Oculus, hopefully there is a fix.

DolanDeering
Level 2

Biobaxane said:

Hi I am new to the vr scene and Ive been experiencing one fatal issue when playing games in steam vr. I launch the game and play it for 10 - 30 minutes and then the game freezes up and wont respond to my menu button at all, hell I even go into task manager and close steam vr and the game I was playing. my gpu is only a 1050ti which meets the minimum specs for the rift s. and Ive turned the settings down in all of the games I play. Thinking about upgrading to an rtx 2060 and seeing if that changes anything but I want to know if anyone else is having this issue too and if so, is it a gpu problem or just some sort of glitchy shit. (I use the oculus tray tool to run steam vr through the oculus menu in the headset If this is the source of the problem then please someone let me know)


Is it just SteamVR that has the issue? Could just be Steam if so...

XxShadyxX
Level 2
Hello,
lately I got some issues with a device. Any idea what can be a fix for it? I have usb on full power.

There are 2 different problems:

1. All mine USB beside one makes Oculus works smooth, but very often controllers got stuck in 1 place and can only rotate + screen is "glued" to my face. So when it happens if you try crouch - whole world crouch with you.

2. One usb (3.1 super fast) have no issue with "freezeng" like above. It makes my controllers to horribly lag when I use buttons. For example: I try to shoot bow - they vibrate and jigling arround on screen. Or shoot with 2 weapons at the same time. Hands are nearly locked in place and jigling arround. The longer you use buttons, the longer "lag" before you can move hands again. So I stop shooting, and have to wait till controllers stop vibrating.

PS: In case 2 - coming close to boundry with controler makes lag as well. When it shows up, controls start lag

SkScotchegg
Level 11
A new problem has started for me, all of a sudden when I get home each day and put the HMD on my head I just get a black screen, and then I have to spend 5 minutes messing about with it and unplugged the cables from the back of the PC and then eventually it works.

It's weird that this has started all of a sudden. I'm guessing the patches have caused this.

I have to restart Oculus Home a couple of times too and then keep unplugging the cables until I get a picture in the HMD but eventually it does work and I can play games for hours.
UK: England - Leeds - - RTX 2080 - Rift CV1 & Rift S - Make love, not war - See you in the Oasis!

Downluck
Level 4
I'm getting a random noisy robotic voice on my microphone, I'm completely disappointed with the support which doesn't help me out at all and didn't even give me some hope as such "We are working on it already, wait for a fix" like they did with the screen flashing issue. I tried everything they asked me to do, now I ended up with the conviction that this is a software issue for sure, just like the flashes. There are other users complaining about it on Reddit and also here, but they are being forgotten. I want to make the staff know about this problem, and if they know already, I just wanted some answers about when it will get fixed. 😕

Thanks for this thread since this is my last post about this problem, considering I'm exhausted by complaining everyday. I think I will be a robot for a while until they pay attention on this and also I'll still being muted by some friends for annoying them as already happened.

BigBadBatch
Level 3
Oculus software keep asking for a restart afrer restart (like a loop) with a red dot close to it.
When headset on me, it turns on and I can hear everything but the screen is black and I got 3 white dots in the middle of the screen.
I have the latest windows update and the latest GPU update as well. Checked my USB if its up to date and even re-installed Oculus software completely from 0.
Trying to setup a new headset didn't worked either it says cannot track headset movement.

Problem started 2 weeks ago.