cancel
Showing results for 
Search instead for 
Did you mean: 

BUG: Oculus Link (Oculus Quest) Frame Timing Instability with MSFS and X-Plane and Oculus Runtime

SwirlyMaple
Level 4
I'm not sure who is to blame for this -- Oculus, Nvidia, or the app devs, so I'm posting it everywhere in the hopes it'll get fixed.

In Microsoft Flight and X-Plane, using an Oculus Quest 2 with Oculus Link, there is a frame timing bug in VR preventing the runtime from locking at the full framerate under any circumstances, and causing lots of microstutters and hitching.

This bug is FIXED by setting the v-sync setting in the Nvidia driver to "Fast" mode. This should not make any difference, as the runtime is supposed to override any v-sync settings, but it does not. This bug is also fixed by forcing either of these apps to launch through the steamVR runtime. Even though steamVR runs as a layer within the Oculus runtime, doing this also fixes the unstable frame timing.

I made a video showing this issue and its remedy very clearly in X-Plane. At the beginning of the video, the v-sync setting is 'let app decide.' In the X-Plane menu screen, despite plenty of performance headroom, the framerate will not lock at the 80Hz refresh rate. When the simulation is loaded, the framerate is a hitchy, stuttery mess. Exiting the sim and changing the setting, and re-launching, shows a rock-solid 80fps and smooth performance once the sim is loaded.


Video:
https://youtu.be/zcgJY-mDxhM

I have tested this with drivers from 442.79 to 460.89 and it is the same with all of them. My system is a 1080Ti, i7 8700k, 32Gb DDR @ 4000MHz, and MSI Z370M GAMING PRO AC mobo. Some others in online forums have confirmed this behavior on their systems too, but I don't know if it is specific to a certain GPU model.

1 REPLY 1

VIZCODE_DEV
Level 3
I can confirm this!! I have an OpenGL app that behaves similar. With vsync set to “application controlled” (and turned off correctly in app), I only get around 65 (63-67) Hz for simple, medium, and large scenes. It seems that there is some sync issues that caps the framerate. Everything gets solved with the NVIDIA setting (vsync set to “Fast”). 
I also compiled the OculusRoomTiny sample (OpenGL version, from Oculus SDK 23.0.0) and I see the EXACT same behaviour. Also in the Vulkan version of OculusRoomTiny…
Latest NVIDIA drivers, Oculus desktop app + Quest updated to latest. Official Link cable. Same for Quest and Quest 2. Tested on two different computer; GTX 1080 and RTX 2060 Super. (And yes, everything is silky smooth when I use the same apps/samples with Oculus Rift S on same computer(s))

Very frustrating!

(Happy to send sample apps if anyone at Oculus wants to reproduce these issues. Still, should be easy enough to just compile and test from your own SDK)

/Mikael