cancel
Showing results for 
Search instead for 
Did you mean: 

Can't login to Oculus account, tells me to update when I am on the latest version

wratioo
Level 2

A few days ago, My quest would not connect to my internet, so I decided to factory reset it. When I did, I could connect to the internet after a few tries, but then I couldn't log in. It told me to update to the latest version. I did that, and when I tried again it said the same thing. It exactly said: "The software on your headset needs to be updated. Go to Settings, select "System update", then select Download to update your headset." I check again and again and there are no new available downloads. I get the option to use a code and input it to meta.com/device, but I also get an error telling me to please try again on my quest, even though It said I had connected on the device I put the code on.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hey,

 

I had the same issue. After merging my accounts to 'Meta', gets me to login, when I try and login, states I need to do an update, but no way off getting of the 'login' screen.

 

However, I clicked 'forgot password', which opened a browser, but also let me access the store/settings area. So, I went to 'settings', 'device', scrolled to the 'about' section, and updated the version from there.

 

The headset reset, updated to the 'meta' logo from 'occulus', got me to login, and then sent me a new pairing code.

 

All sorted now, but only by chance, I was able to get it sorted.

View solution in original post

Uriel_sh
Level 2

Another solution I found, Go to the "Meta Quest" app in your phone and cast the phone to your headset, it solved my problem

View solution in original post

23 REPLIES 23

OculusSupport
Community Manager
Community Manager

Hey there! We see you're experiencing some trouble with setting up your device for some fun gameplay. We definitely want to help get you back into the fun as soon as possible! 

 

We suggest that you uninstall and reinstall your Oculus phone app, and logging out and back in on both devices.

 

If this doesn't help, please reach out to our support team so we can look further into this for you. (https://metaque.st/Support)

 

shellski77
Level 2

Same here

robbcreates
Level 2

Has there been any update to this? Any known fix? Occulus, you've created a soft lock for your own system... 
You won't let the headset leave the pairing code screen without parining. But you won't allow the app to pair unless the headset has an update. Which I can't do because you've locked it to the pairing code screen... 

mginni15
Level 3

Im having the same issue on my device as well, logged into my facebook account on both the oculus PC and mobile app and then the mobile app said i needed to pair it with my headset and when i tried relogging into my facebook account on my headset it just kept telling me to update my headset even though im already on the latest version. I dont know how Facebook is constantly messing up their own software, I feel like i have to contact customer support atleast once a week because they keep sending out updates that are constantly making the quest unusable. Oh also when relogged into my facebook account on the PC app it removed all the games that were in my game library so thanks facebook for being literally the worst thing that could've happened to Oculus.   

Hey there! That's not an experience we like to hear from our customers. We'd love to help you.

 

Can you please PM us so we can ask you account information while keeping it secure?

 

Please select our name to get to our profile page, or click here. Please remember, you must be signed into the community first to send us a private message.

hey, hopefully, you see this. 

I tried again a couple of days after my post here and managed to get it working.

I basically forced the headset to power on/off a couple of times. Holding down the power button and choosing power off. Not sleep or letting it power down when not in use etc.

That seems to have solved it as after 2 or 3 cycles the pairing code stopped being shown and I was able to set everything up. I'm not sure if at some point in the process of powering on/off an update was actually carried out.

I also uninstalled/reinstalled the mobile app. But that was the same day I posted my question here. It didn't do anything then but it might have been part of what solved the issue so it's worth trying. 

With any luck, you can also turn your £400 paper weight back into a working device. God forbid we could actually just use the hardware we paid for without immediately being forced to sign up before even getting into the main system. 

SierraPacificVR
Level 2

I put in the pairing code and the phone Meta Quest apps is saying "Software update required - To access your Meta account and avoid a factory reset, update your device with the latest software..."

 

There is no way to update the headset because it hasn't been paired yet.  We are a development company and I have 6 of these headsets that are doing the exact same thing....  I am getting beyond pissed off.

 

We have over a hundred Quest2 headsets deployed and this is a mind-numbing problem.

Same problem I’m having! Very frustrated!

SierraPacificVR
Level 2

I found a workaround not on the forums.  Download the Oculus update 43 here:

https://drive.google.com/file/d/1-XwU2uFh1O2MytV2w_kjhrBvoavq6kRy/view

 

Boot the Quest2 into SideLoad boot mode from by booting holding power and volume down

 

Here is a guide to Sideloading using ADB:

https://uploadvr.com/sideloading-quest-how-to/

 

Write the update over the old OS and it will now work.