Showing results for 
Search instead for 
Did you mean: 

Certificate Validation Failed in Echo VR

Level 2
I'm using Echo on a Quest 2 with Oculus link. I've recently installed Windows on a new HD, installed GPU drivers, Chrome, Oculus, Oculus Tray Tool, Echo VR.
When I open Echo, I get a Certificate Validation Failed error. This happens before logging in.

I tried disabling Microsoft Defender Firewall but no change. Tried opening Oculus Setup and running a repair but no change. It still works fine on my other hard drive in the same PC.

I checked the logs and compared them to the logs in the working hard drive and found this section:

The error seems to be "cert chain failed Trust Status" but I'm not sure what certificate is being used in order to trust it.

I tested wss:// at websocket. org/echo.html and it connects fine from the same PC. 

Anyone know how to troubleshoot this? 

Level 2
I found a solution thanks to a tip by one of the RAD staff. When i got the error, I connected to my mobile hotspot and disconnected the Ethernet cable, then clicked retry and it logged in, then just turn off the hotspot and reconnect Ethernet and Echo is fixed!

Level 2

This Didn't work for me 😞