cancel
Showing results for 
Search instead for 
Did you mean: 

Creed Rise to Glory won’t save story data

bingus934
Level 2

I just bought Creed and I’ve tried to play the story mode around five times now, every single time I try to play it it resets. I’ve looked at other forums and it seems like a lot of people are having the same problems and even when you allow permissions the game still doesn’t want to save, I’ve tried checking my storage and everything is fine and I’ve tried checking if any other programs have the same problem but they don’t. I honestly don’t know what to do right now and I feel defeated

1 REPLY 1

Tonberry_Qing
Meta Quest Support
Meta Quest Support

Hey @bingus934. I wouldn't want to have to redo everything every time I played a game.  Here a link to an article you can read through that has a lot of FAQs: https://survios.zendesk.com/hc/en-us 

Also, you could try reaching out to the developers support team support@survios.com, or perhaps one of their social handles.  You can find a list of their socials if you scroll to the bottom of this page.  https://survios.com/studio/contact/

I hope you get some answers. If you do, please update us!

Have you tried turning it off and on again?