cancel
Showing results for 
Search instead for 
Did you mean: 

Developer Mode "allow USB debugging" will not show

inane_prism
Level 2

Developer mode is definitely on, but when trying to connect my Meta Quest 2 to my computer, the "allow USB debugging" confirmation does not appear. The only confirmation that appears is "allow access to data", but both need to be enabled for my applications. My computer has ADB drivers installed and has been restarted. My Meta Quest 2 has been restarted along with Developer Mode being turned off and back on. For some reason, it's still not working. I haven't found much information about this online, and support is not really responding to me. Anyone know what's going on?

5 REPLIES 5

OculusSupport
Community Manager
Community Manager

Hey there. We understand you have some questions about developer mode. We know how important having dev mode is to unlocking the full protentional of your headset, so let's see what we can do to help you! 

 

Here is a link that has lots of community answers for your questions and feedback for enabling USB Debugging in developer options HERE. Please let us know if you have any other questions! 

ratajack
Level 2

have you found an answer to this, because I'm having the exact problem and I can't find any solutions

thnk2win
Level 2

Same issue here, anyone get this to work?

Hello! We see that were having an issue connecting your Quest 2 to your PC with Developer Mode. This is not the experience you want you to have at all!

Sometimes this can happen when Developer Mode is not enabled properly, which is why we would like for you to please check if it is turned on in the mobile app with the following steps:

  • Open the Oculus app on your phone.
  • Go to the Device tab on the bottom menu (the headset icon).
  • On that page under the Headset settings, there is an option called Developer Mode.
  • The developer mode connection permission pop up appeared on the headset.

Another thing that you can try to do, is to download the Oculus Developer hub and look for the "allow USB debugging" there to fix the issue.

We also want to invite you to post in our Developer Forums that way our awesome community can provide more information and help!


Hey, @thnk2win! We see that you are having issues connecting your Quest 2 to your PC in developer mode. We are sending up a flare to see if you are still having the same issue. If so, please select our name to get to our profile page, or click here: https://metaque.st/community-support. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. We will be happy to help you out. Happy Turkey Day!