Showing results for 
Search instead for 
Did you mean: 

Fatal Exception in Direct HMD, Extended shows both screens

Level 4
To start, my rift DK2 worked ok (other than some dead pixels) before under Windows 7. I decided to try the free windows 10 tech demo, which worked amazingly.. until last month. Last month or maybe even earlier now an update came out that broke the rift under windows 10, so that it wouldn't be detected by the software. I finally decided to go back to windows 7 today, but now after installing all my video drivers, and the rift software, I'm having a new issue.

In Direct HMD mode, if I try Show Demo Scene, it gives an exception and crashes. If I set it to extended mode, then I can see both screens displayed in both eyes - rather than one screen filling each eye - but other than that it seems to work.

Is there any solution to this problem? My video drivers are up to date as I said, as well as the oculus software being the latest one freshly installed, and the firmware is updated as well.

Thanks for any help

Edit: I just realized there's 177 windows updates after Service Pack 1.. I'll install those and see if it helps for now

Edit: Problem is the latest nvidia drivers that end in .09, they cause this. Solution is to roll back to .75.

Level 15
The double-screen issue is the Nvidia drivers. You need to use 344.75 for now.

The Direct Mode crashing is more interesting to me. What are your system specs?
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

Level 4
Yeah Direct Mode is still crashing for me, opens a large window "Exception encountered in RiftConfigUtil", with tons of info about my computer - but I can't see anything actually saying what the problem is

Again this is a fresh reformat, and my rift has worked fine under Direct in the past.

I am on a GTX 660 2gb
8gb ram
Windows 7 64 bit on 120gb SSD

Level 2
Well, good to see the problem has already been tracked down. I was wondering why I was getting this.