Showing results for 
Search instead for 
Did you mean: 

Intentional malfunction rift/rift s

Level 3

I have noticed a lot, i mean a LOT of posts about rift or rift s crashing, or usb ports not working, or in some cases usb port malfunction causing all usb devices to reset/restart.  Now i dont work for oculus so im not going to pretend that i am 100% correct in what im going to tell you, i can only tell you my experience. But i believe oculus support has engineered the rift/rift s headset to purposely malfunction. This is do to the fact that they are phasing them out completely,  so when i first started with my rifts s i was using an Asrock b365 phantom gaming 4, with intel core i7-9700k, EVGA gtx 1050ti, 24gb ram and 700watt psu, and it worked not the greatest but it worked, so i upgraded gpu to gtx 1650, again much better all around with rifts, but i wanted better, so i again upgraded to radeon rx 5500 xt mech 8gb by msi. Beautiful! Never a single issue, no lag no crashes, ever. And the someone actually stole my card, broke into our house while we were gone and took only my gpu, strange right? Turned out to be someone i knew, anyway, card never was recovered, so i went back to the 1650, and then i started getting crashed like 2 minutes after selecting a game, from my oculus games or steam, didnt matter, so i found a gtx 1650 super, thinking it would be much better right, since 1650 used to work pretty good. Turns out the super is even worse for rift/rift s. And there were numerous troubleshooting efforts between myself and oculus support, with ridiculous suggestions, such as try using it on another computer,  or did it ever work before, and stuff like adjust the usb power setting, uncheck the box that says let windows turn this device off. Just childish suggestions that i had already tried before i even contacted them. Bottom line was i was told to get a different graphics card period. And was given a list of supported cards, excuse me, recommended cards, and sorry to tell you the 16 series nvidia cards along with all rtx 20 series cards will NOT work with rift/rift s. The recomment 10 series cards over rtx 20 series,  can you believe that, obviously inferior cards, but they will work for sure with oculus rift s. And of course rx cards are in hands down from r9 370 up and rx 460 and up. Oh, rtx 30 series cards allegedly work good also but ive not seen one in action. Anyway ive concluded that they intetionally set up the rift/rift s to fail so that you will buy an oculus quest 2, because they dont want to offer support for the rift series anymore. 


Level 3

Glad I'm not the only one that thinks this is intentional. I bought my Rift S with my 1400 stimulus check and was only able to use it for a week. Then I updated the app to v27 and that's when it all started, giving me the 3 Dots of Death and everything.

Level 3

I honestly can't see Oculus intentionally disabling the Rift. Unintentionally, through disinterest, yes, absolutely but not intentionally. Oh and RTX20 series cards work fine with Rift S. My RTX2080 is testament to that.

I would love to believe that the rtx 20 series works fine, however mine did not, and i was even told from oculus support agent, that the 20 series is not compatible. If yours is working, then id have to say either youre one very lucky person, or you have found the one true component combo that will work, in which case would you be willing to share what build you are using? 

Thanks for taking the time to read my post, i am curious about the 3 dots of death, ive not experienced this,(yet). Could you describe it please? 

Level 2

Same here, my rift s dont work anymore with the app update v27, I tried everything in my pc to, but worst of all, I tested it on my friends' pc, in exactly 5, of which two had the last rtx 3080, and in all of them the same error comes out, "headset sensor check failed" try another usb, it's like in the last update, they didn't make any usb work with the oculus. in my case. A shame, but clearly my next VR is not going to be from Oculus.

Basically when you put the headset on, instead of it showing the home screen (where you select your game or to mess with the settings) it shows a constant loading screen which is a black background showing 3 dots. As if it's loading something, but it never does.

Level 2

I'm in total agreement . If Oculus is going to do this to a customer .. my next buy will definitely NOT be an Oculus headset ... PERIOD ... Rift S has the worst support team out there ... NO PRIDE !  


Level 2

I have the same problem, card gtx 1070ti, before update v27 everything was OK, now even i oculus room not working. I tried to buy powered USB 3.1 Hub- same **bleep**, i bought a good usb 3.1 pci card, thinking maybe he needs better power.I spent a lot of money. SHAME ON YOU! OCULUS.

Level 3

Like many others on this forum, my rift-s stopped working after update to v26, 3 dots on screen...went thru oculus support back and forth for the past month or so.

Basically, if your cpu is old, you are pretty much screwed with no official way to downgrade to earlier working software version. They'll blame it on your old computer and that you should upgrade it.

But I know its their software that broke it, it was working perfectly fine with v25.


With the production halted on the rift-s and their focus on Quest 2 being their main product, don't expect much support from Oculus on this going forward.