cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link Microphone not working

QuinnBrom
Level 2
Anyone else have the issue where the mic doesn't work through oculus link? It shows up in windows but stays at a constant level. I've reinstalled all oculus software, made sure all the microphone settings were on, and setup right and tested my quests mic standalone and it works fine. Also, it was working fine for about 6 months and just randomly stopped working one day, I'm hoping it's just a recent update that bugged it. and will be fixed soon. I do hope that someone might have a solution though. Thanks
5weph60ctpiy.png
28 REPLIES 28

Aphinity
Level 2
I'm seeing the same thing on my girlfriend's PC with her new quest 2 that I bought her for xmas. 

The Mic works fine over Link when connected to my PC, but gives the same mid-level result in windows sound control panel or settings/sound when connected to her Acer Nitro 5.  Sometimes, fighting with things long enough, it will suddenly start working. I have no idea what I do to make it work as it seems different every time.

I've tried the suggested process of removing the "exclusive control" checkmark in the control panel/sound (not in the windows 10 settings, in case others are looking for it), and it might have worked once, but after that, it fails again.

I will try the reboot of the computer next time we're troubleshooting this.  I know for certain I've rebooted in the past and found no change.

It's extremely frustrating to have a new device and have to use a separate headset and mic for it, which is what we wound up doing until this is fixed.  It's very clearly a software problem that I hope Oculus is planning to fix.  I run into people every single day on VRchat that have given up and use their own external headset because of this bug in Oculus' software implementation.

Zandil
Level 8
Having the same issue, the quick workaround I use atm is this.
Connect to the PC in VR, open any app that wants to use your Mic, (I use discord), hit disable Link in oculus home settings, this will send you back to quest 2 menus, hit enable link cable again and my Mic works fine until you turn PC or quest off, then rinse and repeat. (for me there is no need to physically unplug the link cable)

Currently, Oculus wants to change over my quest 2 under warranty for this issue, but somehow I doubt it's an issue with the hardware, seems more like a windows permissions issue. 


LioDeBeer
Level 2
Zandil's suggestion worked for us on 3 different computers that keep hitting this issue.

StrunzVR
Level 3
@Zandil suggestion worked for me too 🙂

BlackShark3D
Level 4
I have the same issue as you all.
  • Windows mike monitor says the mike has a constant 50% volume even when the Quest is OFF
  • Audio output to the headset sometimes does not work upon first connect
  • Mike input from the headset never works upon first connect
What I do is : I make sure I select both Oculus Headset as the default audio and default mike. In the old school windows control panel mike properties, I activate the mike's self-listening checkbox as a loopback test. Then I restart the Quest 2 using the side button over and over until both the audio and the mike works.

I try Zandil's solution of just restarting the link instead of the whole device, but sometimes the link no longer  appears the Quest main menu, so I figured restarting the whole Quest2 was more reliable.

cookie_shark
Level 2

Zandil said:

Having the same issue, the quick workaround I use atm is this.
Connect to the PC in VR, open any app that wants to use your Mic, (I use discord), hit disable Link in oculus home settings, this will send you back to quest 2 menus, hit enable link cable again and my Mic works fine until you turn PC or quest off, then rinse and repeat. (for me there is no need to physically unplug the link cable)

Currently, Oculus wants to change over my quest 2 under warranty for this issue, but somehow I doubt it's an issue with the hardware, seems more like a windows permissions issue. 




This is the only thing that worked for me and i don't understand why

gabrielperez250
Level 2
@Zandil workaround is legit! I used Voice Recorder on the PC side. My setup is Aurora 10 and a Quest 2. 

BlackShark3D
Level 4
I confirm Zandil's solution works quite well.
Just turn off Oculus link and turn it back on is quicker and easier than a whole restart.

I only need to perform a full restart of the headset when coming out of a charge cycle (link not showing in the menu)

Greekanadian
Level 3
When first loading up Oculus Link, the mic will not work in Windows.

Go into sound settings, make sure Recording is set to the Oculus Virtual Audio Device

Unplug the Quest 2 from your PC, plug it back in again. Now the mic should work.

You will have to do this every time you restart your PC, but will otherwise work nonstop until you restart your PC.

wilza7
Level 5
Kudos to Zandil.  Ran into this issue today.  After much faffing about and failing miserably to get anywhere, his workaround got it working.  cable unplug/replug did nothing useful.  Disabling enhanced sound and exclusive access (when found where its now hidden - right click sound control by the clock) did nothing either.  various videos about just setting the right devices no use neither.  though the PC does seem to have a zillion sound devices now!

The Windows Sound settings for the microphone still shows the thing stuck at 50%, but the game worked with the oculus microphone all the same.  4 hours of troubleshooting later....