cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2: right controller stopped working

co_ro
Level 3

TLDR; the controller continues to loop on a firmware update and blink SOS. Next, from the Meta app, I unpair and repair the controllers. It "updates" and says success. It also says the same thing in my headset. But, right after the success message in my headset, the headset says the controller is disconnected.

 

Long story: I was playing Bait, and suddenly, the controller died. I removed the batteries and put them back in. The controller started vibrating uncontrollably. I gave up and went to sleep. The next day, it seemed to work fine. But, during Beat Saber, it lost the haptic feedback. However, I was still able to slice and dice. So I switched to The Thrill of the Fight. It worked briefly (haptic feedback) and then stopped again. I begin experiencing disconnection and persistent vibration.

 

After a lot of reading, I tried the foil bed, a paper bed, unpairing, and reconnecting. Throughout this trial and continuous error, I'm getting the SOS blinking on the controller. Next came the firmware update. Which I foolishly think will fix the error. When it didn't, I gave in and did a factory reset, which was a stupid idea. I had to use the Oculus button to return to the home screen. For a brief moment, I was able to connect long enough to get past the setup and land on my home screen. I start the process over, battery swapping, unpairing, and repairing. Throughout that experience, there was a supposed firmware update every time. 

 

Now, the only thing that happens is, after removing the battery and unpairing and repairing, the controller is blinking the SOS message. I did reach out to support and have been fortunate to work with someone who has kept me informed. However, I figured I'd see if anyone has further suggestions that may work.

 

Within the Meta app, sometimes the controller is acknowledged (with the battery percentage.) Sometimes it is not. At this point, every time I remove and re-insert the battery, unpair, and repair, I'm getting the continuous "successful" firmware update loop and SOS blinking.

 

Note: I have a Mac and am not downloading the Windows software for further exploration.

6 REPLIES 6

MuscleFlex
Level 3

have you fixed it?

Meta replaced it and I bought a new one. I guess you can’t have too many right-hand controllers. 

Mine stopped working today 😞
How did you contact Support? Thru the forums or do they have a direct approach?

I chatted with someone through here

MuscleFlex
Level 3

Thanks bud. How long did it take for the replacement controller to arrive?

It was less than a week after they got my return.