Showing results for 
Search instead for 
Did you mean: 

Oculus Software refusing to install on secondary drive

Level 2

I'm about to grab an Oculus Quest, my first ever VR, and I'm planning on connecting it to my PC via Link cable. I decided to try and download the software beforehand so I can have it up and running by the time I get it. However, I've noticed that it automatically tried to install to my C drive, which doesn't have enough space. I found out how to let it install to a second drive but when trying I get the error saying "The drive you selected doesn't meet the requirements for installation. Oculus Requires 15.2GB on an internal NTFS drive."


Now I know my drive is in the NTFS format, and it's 1TB. So I decided to move all my important files to my larger drive and format the D drive just to make sure it's an NTFS drive and Windows will recognize it as such. However, after 1 hour and a half of formatting, the setup tool is still spitting out the same error message saying the drive is ineligible. I'm kind of stuck, but just in case I can't get this remedied, I'm gonna buy a larger MBR drive and clone Windows (I needed to upgrade anyways, been stuck on 120GB) so this issue doesn't pop up. But I'm wondering if there's an actual fix for this. Any help is appreciated!

EDIT: Extremely late, but I was able to get it installed using the command prompt and it finally started working after like 6 tries


Level 13

Copy the setup program onto the secondary drive and run it from there.  The setup file must run on destination drive to unpack and write to it.

Level 5

i helped someone yesterday with a similar weird error.  turned out the oculus software doesn't like dynamic disks type.  have a look in the disk manager tool.  is it a dynamic or basic disk?