Showing results for 
Search instead for 
Did you mean: 

Oculus lik recognize connection as USB 2.0

Level 3
Good evening and happy new year!
I'm using my oculus quest 2 with a "CableTex usb-c to usb-c 3.1 5m" but i'm not getting it recognized as a 3.0 but only as a usb 2 (at -+ 350Mbps).
My motherboard is a "MSI MAG B550 tomahawk" (mounted i have a ryzen 9 3900x, 32 gb ram and an msi gaming x rtx 2060super); i'm getting the same result through all my usb C ports:
-1 on the front (connected to the internal motherboard connector which is  a 3.2 gen1 usb c)
-1 on the rear io (direct from the motherboard which is a 3.2 gen2 usb c)
-1 on the rear pci expansion card (it's a supageek pci expansion card, which theoretically from the amazon spec. is 3.0, although it says in the description that it is NOT compatible with oculus rift; anyway is working fine but recognize as usb 2 as the others)
From Device Manager in windows 10 pro it says that my ports are 3.1/3.0 but i know that there are some misleading in the meaning of usb 3.x genX; so i think that windows is operating those ports just fine.
I tried flipping the usb c cable the other side (even if it should be "specular" but i read that some time it works) and i tried like 10 other cables (usb-a to usb-c) that i had laying around (2 of them i know in fact being 3.1; the other were spares that could be 2.0) to different ports (rear and front ports, so all 3.2 gen1 5Gbps and 3.2 gen2 10Gbps); but the result were the same: recognize as USB 2, and working at "only" -+ 350Mbps.
So i'm here to ask for assistance, the oculus link IS working but i can't activate 90hz mode because it recognize the connection as USB 2.0.


Level 3
I want to share my experience, hoping it would be helpfull for others too, as the problem is fixed for me!

Oculus Support reply (i have to say that you have a great support staff, if they are all like this)

Hello Giuseppe,

Thanks so much for reaching out to Oculus Support. I appreciate all of the photo you sent, it really helped me understand your concern. I would be glad to assist you regarding your USB concern. 

I can see that the you've an encountered an issue where you're USB 3.0 ports cannot be recognized and deemed as USB 2.0 ports. I'll be more than happy to assist.

I would like to look into some USB settings with you to rule some things out as a possible cause for your issue. Please follow the steps below:

  1. Open Control Panel.
  2. Click on Hardware and Sound.
  3. Click on Power Options.
  4. Under "Preferred plan," click the Change plan settings link for the plan you're currently using.
  5. Click the Change advanced power settings link.
  6. Expand USB settings.
  7. Expand USB selective suspend setting.
  8. Make sure this is disabled.

Once those are complete, I would like to ask you to look into your USB Power Saving settings:

  • Right click the Start menu and select Device Manager.
  • Scroll down and open the USB (Universal Serial Bus) section.

After you are in the USB section, please complete each step below for each USB item:

  1. Right click the first option and select Update.
  2. Wait for this to finish.
  3. Right click the first option and select Properties.
  4. Open the Power Management tab, and uncheck the "Allow this device to turn off" box.
  • The tab might not be there for all entries. If missing, move to the next one.

Restart your computer after completing these steps.

Please let me know if it worked, I look forward to hearing from you soon.

Kindest regards,
Oculus Support | Facebook Reality Labs

And my reply/experience/fix

It worked!
I already had my "usb selective suspend" disabled.
From the device manager all of my usb drivers (under usb universal serial bus) seems to be up-to-date.
So i have done 2 things:
-Unchecking "Allow this device to turn off" in power saving tab for each usb bus i had in my list.
-Update my chipset driver manually from amd (having an msi motherboard i usually use Dragon Center, which gives me the latest driver); the strange part here is that the version number seems to be older than the one that i had before, and the update has been kinda "fast" so i don't really know if it updated the drivers packet for real but.. ok.

Now plugging in the rear usb-c (directly on motherboard io), but in only one specific way(it doesn't recognize it "flipped"), works as intended and the oculus software recognizes it as 3.0 2.8Gbps [see attachment]. It still doesn't recognize it correctly on the other ports, but I only need 1 obviously so no problem!
Thank you, and again, have a beautiful new year!

Best regards,

Level 3
And it stopped working pretty quickly (oculus recognize it again as a 2.0 usb connection), so if anyone has any suggestion..!

Level 2
Just want to say I'm having the same issue and I've tried all of the above. And I'm using the official link cable. My motherboard is a b450 tomahawk max.

Level 3

I've tried everything: reinstall the OS, "upgrade" from Win10 to Win11, install Intel drivers, install MB manufacturer drivers, delete the device in device manager and reinstall, use different cables, flip cables, sacrifice an old USB 1.0 cable to the computer gods... nothing works.


SO many people are having this issue (Google it), it's amazing it's not properly fixed.

Hey there, StuntPanda. We don't want anyone to experience this, and we would like to collect your logs via support. Send over the logs in a support ticket and we will be able to help you out!


To extract logs from the last day:


  1. Open the Run window (Windows key + R).
  2. C: Enter and run/Program Files/Oculus/Support/oculus-diagnostics OculusLogGatherer.exe
    • The above link is the default directory. Bear in mind that if you installed the Oculus PC app on another drive, you will need to update the command with the correct file path.
  3. Select the checkbox next to "Full logs".
  4. Select "1 day" from the "Collect last" drop-down list.
  5. Wait for the log collection to finish. This can take some time to complete.
  6. The program will automatically generate a zip file containing your logs, which will be saved to your desktop automatically.
  7. Attach the newly created zip file to your next support response.

I fixed it; I bought a better cable. I thought I had a really good cable but I guess it just wasn't good enough. Hey, that sounds like a Country & Technology song, I Guess My Cable Just Wasn't Good Enough.