cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus quest 2 goes to sleep in a few minutes

isingo
Level 3
I'm trying to watch Amazon Prime Video on Oculus quest 2.
But after a few minutes of watching the video, the screen goes black.
After that, by pressing the power button, the screen turns on and the Video starts playing.
Perhaps it seems that not moving the head is causing a problem.
Not moving my head for a few minutes causes the same problem with the Oculus Home.

I changed the time to sleep setting to 4 hours, but it still goes to black.
After trying many things, I found that the only way to keep it from turning black was to keep moving my head.

I want to watch Video without moving.
Please let me know if you have any solutions.

63 REPLIES 63

Nio_KBX5463
Level 2

Hey man, I too have been experiencing the issue for some time and it has been getting on my nerves quite a bit. However I did find something. (If you're not on pc it wont work, pc users only.) What helped for me for sometime was going to this file path 'C:\Program Files\Oculus\Support\oculus-diagnostics/OculusDebugTool.exe' When opened you'll be greeted with a white window with option's. Under the "Service" category which should be open automatically, Find something called 'Bypass Proximity Sensor' and turn that on. Then that worked for me. Share this to all the pc user's u can find with a quest 2, and hopefully it will work for them aswell. Have a good day 🙂  

Pixie40
Level 11

There should, I think, be an option in Settings for this. But if there isn't, there's always the old stand by of moving a controller or your hands periodically, just to let the Quest know you're still there. Yeah, it's a work around. But it's no different then periodically coming over to hit spacebar when playing an MMO to avoid getting logged out for being AFK too long.

Lo, a quest! I seek the threads of my future in the seeds of the past.

As the forums suggested, the option isn't working. An MMORPG point would be valid, except some people in this forum literally can't watch Netflix or Amazon Prime without their headset turning off within minutes. The further bigger point being how long this one issue has been ongoing. Checking your AFK status now and then would be one thing, having to be a bobblehead or flick your wrists to watch content on a VR headset is another. 


@Popskadins wrote:

As the forums suggested, the option isn't working. An MMORPG point would be valid, except some people in this forum literally can't watch Netflix or Amazon Prime without their headset turning off within minutes. The further bigger point being how long this one issue has been ongoing. Checking your AFK status now and then would be one thing, having to be a bobblehead or flick your wrists to watch content on a VR headset is another. 


Last time I launched Netflix in VR I'd done so with a few friends. We weren't actively trying to keep our headsets from entering sleep mode. But we still ended up doing so while chatting during the movie.

 

Just jumped in for a test. Launched Netflix, queued up a half hour long show. Put down the controllers. And... the headset did not turn off on me during the show. I haven't changed any settings, and the headset is set to go into sleep mode after 15 seconds of inactivity. And yet, I was able to watch an entire episode without the headset turning off.

 

I wonder, what do I do that's different then others. Is it possible that it's because I don't sit 100% perfectly still the entire time? I shift in my seat, I look around on occasion, especially if watching something on a virtual screen that's huge. In short, I don't imitate a statue. Maybe that's all that is actually needed.

Lo, a quest! I seek the threads of my future in the seeds of the past.

This bug is back for me. Mid watching content the headset goes black and shuts itself off. I can’t believe after two years of updates, Facebook with all their remarkable engineers can’t fix this simplest problem to not turn off the headset when it’s on my head. How hard is it? Why is ‘never’ not there as an option in the power settings for auto shutdown??

Ty 😊 

whdwidbr9
Level 2

Hi. I'm Korean.

That's why English may not be natural.

When I was lying down while playing games, 2 minutes? The screen turned off every 2 minutes.

I worked really hard to solve this problem. I figured out the answer.

What we need is... be a Oculus developer Hub

 

1.https://developer.oculus.com/downloads/native-android/

We need to install the Oculus developer hub here.

2.We need to change Oculus Quest 2 VR to developer mode.

On your cell phone application, Enter the device tab. activation of developer mode

For developer mode, https://developer.oculus.com/manage/organizations/create/  need to get in here and form an organization

3.Once the developer mode is complete, Connect VR to PC. At this time, USB debugging or other things appear on the screen. press "Allow".

4.

adad.jpg

I turned on the Oculus developer hub. If Oculus was recognized like this, As you can see in the picture,

Proximity Sensor Proximity Sensor turns off this item

That's END!  Even if I lie still, it won't turn off.

And if you want to use it wirelessly, Turn on ADB over Wi-Fi. <- be located on top of the Proximity Sensor

It worked for me - fantastic! How on earth did you figure this out??

Glad it worked for you MegaFlops. I figured it out by trial and error.  It made sense to me.  I do know that you may need to do it more than once.  Sometimes I just keep the controllers disabled while I'm watching a movie.  Either way...cheers to you.  

airmouse
Level 4

V39 problem still persists