cancel
Showing results for 
Search instead for 
Did you mean: 

“Please update your headset firmware to the latest available version and try again.”

josh.756243
Level 2

522E974F-35EC-4F8A-8D0A-260A2066289F.jpeg

4DBF6F40-C7F7-4253-8E48-3AF8A16AA0C5.jpeg

So, there have already been plenty of posts around of people having trouble connecting their meta quests to their phones, i found a potential fix on Reddit (I posted the picture explaining the process), but after my headset pairs, it displays this screen, if i click next (that’s what the blue button usually is) it says i need to update my firmware, but obviously i’m doing this so i can update my headset, so i’m stuck here. 

2 REPLIES 2

Pitesa
Level 2

I have the same problem.

DominatorVIP
Level 6

I just made a similar post seeing if anyone has any ideas. I tried manually sideloading the most recent headset release (V43) and I still get the same error you do, save the fact that I have the original Quest-1 and not a Quest-2.

 

@OculusSupport Any insight into this issue?