cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 PCVR stutter (Alyx/Boneworks) (Link cable, AirLink, VirtualDesktop)

kkthxbye1
Level 3

The problem:

 

Roughly every 1-2 seconds, there's a small judder/stutter in PCVR games when moving. It's almost like a previous frame is rendered again. It is very noticable in alyx and boneworks using the joystick to move left/right and looking at a static object. I assume people playing with other movement types wont notice it easily.

It does not show:

  • On steamvr frame graph
  • On any of the oculus debug tool performance overlays, performance is rock solid on all graphs.
  • On the desktop window fro boneworks/alyx
  • On the steamvr vr view

Only shows in headset.

 

It occurs:

  • In alyx using steamvr
  • In boneworks using steamvr
  • In boneworks from the oculus store

I have tried two PC's:

PC#1

  • Intel i7 8700K
  • 16 GB 3000mhz CL14 RAM
  • Nvidia GTX 1080

PC#2

  • AMD Ryzen 5800x
  • 32 GB 3600mhz CL16 RAM
  • Nvidia RTX 3070

Most testing has been done on PC#2, but the experience is exactly the same.

 

What I have tried:

  • Official link cable, airlink and virtual desktop
  • Factory reset headset
  • Fresh windows install with only oculus client and steamvr installed, nothing else at all
  • Disable game mode
  • Turn off super sampling in steamvr (pretty much all combinations of steamvr/oculus settings)
  • Turn off ASW in oculus debug tool
  • Turn down all settings in game and run at lowest resolution in both oculus and steamvr. This in turn ran alyx with a frametime of about 1 ms.
  • Raised priority of all combinations of involed processes (oculus server, vrserver, the game etc.)
  • Used all combinations of the common alyx launch options.
  • Disable game mode in windows
  • Set the CPU/GPU profile to level 4 via. sidequest.
  • 72hz, 80hz, 90hz, 120hz (vd)
  • More stuff I forgot probably

Note:

  • I get 2.5 gbps on the USB test
  • There is no delay using airlink or vd. VD shows no network latency spikes. I run 2.5 gbps LAN to a wifi 6 router.
  • Nvidia drivers are the newest.

I have read countless of topics complaining about steamvr/alyx/boneworks stuttering.

 

My first thought is:

 

It might be the nvidia driver thing:

https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/402768/valve-index-missing-dropped...

 

However it seems like it should be solved unless you run GPU monitoring software, which a fresh windows install obvously doesn't have. Odds are that this might not be the case, but everyone with new nvidia drivers should experience it, and some people claim to have a completely smooth pcvr alyx/boneworks experience? Are they just not using smooth locomotion and not noticing it?

 

My second thought is:

 

My headset is either broken or the stutter is a software error, either with the oculus compositor/encoder or the decoder on the headset. Again here, other people should experience it.

 

Third thought:

 

It's just a general thing with quest 2 and people just don't notice it? I experience no issues at all with native headset games.

 

I have only had the quest 2 for a couple of months and while I've enjoyed native games (mostly beatsaber), it has been a huge dissappointment having so many issues with PCVR.

 

Anyone have any advice at all? I'm about at that point where I consider returning it as defective.

 

If you want to test it, just boot up alyx or boneworks, look at a static object fairly close to you and move left to right to left continuously (smooth locomotion). You should see a small stutter every once in a while.

67 REPLIES 67

I only played Demeo on VD as well, an I noticed it there as well.

And actually the fact that it happens to both of us makes me think its not our HMD. MAYBE a weird connection with the router, but why would it happen on VD an not airlink?

I have tried different routers wifi 5 and 6, always connected through cat 6 to my PC, separate channel, but it happens through regular link for me aswell through different USB ports and different mobos, HL Alyx, Asgards Wrath, The walking dead SS, Blade and Sorcery, Lone echo are the worst of the games I have.

Skyrim VR, Fallout 4 VR, Arizona Sunshine, No man's sky VR, Zero Caliber, Beat saber etc do not have this problem, so it is either certain games and people don't notice, or our HMD ( no problem with Native apps) but might be something in the encode/decode process, or ATW errors as this is nothing like the ASW artifacts which are more wobbly.

So weird, and annoying. The worst part is that Airlink is super stable but such bad resolution compared to VD.

Airlink is equally bad for me, i would love to have atleast one viable option, as it is now i just get annoyed and taken out of the experience whenever i use the Q2 for PCVR.

lilyz_dad1976
Level 2

Im using quest 1 but this is a problem with the oculus software. 

i had the same judder on my system last summer after an update. I had to wait til the next update which fixed it.  Never had another problem with it. 

fast forward to yesterday when v35 installed itself. The judder has returned. 

i’ve only tested dirt rally and surv1v3 (steamVR) but they are now basically unplayable. 


 

lilyz_dad1976
Level 2

Im using quest 1 but this is a problem with the oculus software. 

i had the same judder on my system last summer after an update. I had to wait til the next update which fixed it.  Never had another problem with it. 

fast forward to yesterday when v35 installed itself. The judder has returned. 

i’ve only tested dirt rally and surv1v3 (steamVR) but they are now basically unplayable

I have Quest 2 and I have this issue specifically with VD. With Link (cable or air) I also see it but it's not as noticeable as with VD.

Hope v35 doesn't screw me over as well.

anzbert
Level 3

i used to play steamVR games just fine with my pc, link cable and the quest2. tried today and it is unplayable. my hardware is definitely fast enough (rtx3080) and it used to work beautifully.

maybe it is the new oculus firmware v35? not sure...

 

addon: oculus desktop VR games work smoothly , except for the occasional link disconnect.

 

Q2 - PCVR  via link cable  immediately shows when connected, grey "borders" left/right of Oculus app home screen. There I see colored hairlike lines as I turn my head left and right. Like thru a triangular crystal prism. I've never had this view before. Just forget playing anything as visual distortions destroy any immersion! I then restart Reboot and VOILA , same THING when link is again restarted. Trying repair w/Oculus app and hope it is over.

 

Repaired with Oculus PC app, Repair Option and It all works well now. Yippie!

dontpokethebear
Level 3

Hi OP, I have this exact same problem. Ryzen 3700X, RTX 3080. I have a Quest 2 and VD, Airlink, and Link Cable all have the same issue. Boneworks, Alyx, and Blade And Sorcery all exhibit the issue. Might I ask: do you or anyone else experiencing the issue have a high framerate and/or Gsync/freesync monitor?