cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 crashes, but games on steam vr keep running perfectly fine on pc, link cable

careepi
Level 2

The title says it all, I've been trying to play skyrim vr through steam vr but after some time (random) the oculus just crashes but the game keeps running fine on my pc, I don't know why this happens, my drivers are completely updated.

These are my specs:

8GB Ram

AMD Ryzen 5 2600 Six-Core Processor
NVIDIA GeForce GTX 1650 Super

 

I'm guessing the problem is with the headset, rather than my pc. Any help is appreciated!

3 REPLIES 3

OculusSupport
Community Manager
Community Manager

Hey there! We know how discouraging it can be for PCVR to not work, so we'd love to provide some insight!

 

In order to gain some insight, could you please answer the following:

 

  1. When was this first noticed?
  2. Has Link via cable worked before?
  3. Is this an official Link cable, or a 3rd party?
  4. You stated your drivers are up to date, that would be the Oculus (see below) and GPU drivers? 
  5. Is Windows also up to date?

 

Also, could you test out these lengthy steps below:

 

  1. Check Oculus drivers for updates:
    1. Close the Oculus app.
    2. Press the Windows key + R on your keyboard to open the Run command.
    3. Enter C:\Program Files\Oculus\Support\oculus-drivers.
    4. Open oculus-driver.
    5. Open the Oculus app and then try to connect your headset again.

 

  1. Check your USB power save settings:
    • Open Device Manager.
    • Locate your USB ports - Expand the universal serial bus controller section at the bottom of the list.
    • Look for the "USB 3.0/3.1/3.10 eXtensible" items.
    • Right click and select Properties.
    • Navigate to Power Management.
    • Ensure that the options to save power are deselected.
      • They won't all have this option, skip those. 

 

  1. Clean install Oculus Home:
    1. Disconnect the Rift/Link cable from the computer
    2. Disconnect your computer from the internet
    3. Backup any necessary content
    4. Reboot into Safe Mode
    5. Uninstall Oculus Home using the Control Panel
    6. Delete all Oculus folders from the following folder:
      • C:\Program Files
    7. Remove any Oculus folders from the following locations:
      • C:\Users\YourUserProfile\AppData
      • C:\Users\YourUserProfile\AppData\Local
      • C:\Users\YourUserProfile\AppData\LocalLow
      • C:\Users\YourUserProfile\AppData\Roaming
      • C:\OculusSetup-DownloadCache
    8. Restart your computer in normal mode
    9. Reconnect your computer to the internet
    10. Install Oculus Home again using the setup tool from our website here
    11. Reconnect the Rift/Link cable and re-test the headset

 

Let us know if this seems to be of any help! 

careepi
Level 2

I have tried these steps before, as they were given as an answer to a similar problem of mine on these forums. Unfortunately they did not work.

 

As for your questions:

This was first noticed around a month or two ago when I was playing Blade & Sorcery on SteamVR, however I had thought that it was from the game itself, due to the amount of mods I had installed (I was also used to it crashing from time to time when fighting several enemies at the same time, so it did not seem like a problem with the Oculus at first)

Link via cable has definitely worked before as I had used it to play a number of games, such as VRChat, Job Simulator, SwordsmanVR, SkyrimVR, Blade & Sorcery, as well as several small free VR games on Steam. I have also played The Witcher 3, Oblivion, Portal 2 and Sailwind through a third-party software - VorpX.

The link cable is official, yes.

Yes, the Oculus drivers and GPU drivers are up to date.

My Windows is indeed up to date, however, I am not sure what does that have to do with the Oculus crashing.

I have noticed I can restart my Oculus and continue my game directly after connecting back through the link-cable, however, it is quite aggravating when I have to do it several times in the span of 30 minutes.

@careepi I do want to chime in here and ask a couple of questions as well.

 

  1. Does this only happen when trying to use SteamVR, or Meta Quest games as well?
    • If only when trying to use SteamVR, you might want to reach out to their support.
  2. Did anything change around that time when you first noticed? (Headset, pc, software, app update, etc.)
  3. Do you have any overlays on in your PC? (Be sure to disable any that might be on)
  4. Is there any integrated GPU? (These can cause an issue as it might be reading the wrong one)

 

If anything you might want to get your logs:

 

  1. Open the Run window (Windows key + R).
  2. Enter and run: C:\Program Files\Oculus\Support\oculus-diagnostics\OculusLogGatherer.exe
    • The above link is the default directory. Bear in mind that if you installed the Oculus PC app to another drive you will need to update the command with the correct file path.
  3. Select the checkbox next to ‘Full logs’.
  4. Select "1 day" from the "Collect last" drop down list.
  5. Wait for the log collection to finish. This can take some time to complete.
  6. The program will automatically generate a zip file containing your logs, which will be saved to your desktop.
  7. Attach the newly created zip file to your support response.

 

Once you have those, feel free to make a support ticket where they can take a bit of a deeper look into there.