Showing results for 
Search instead for 
Did you mean: 

Quest 2 keeps resetting guardian

Level 2

So I’ve been playing some quest 2 games and for some reason every couple minutes it makes me reset my guardian. i have good lighting in the room but it’s still happening.


Level 2

Ever since the update(I was forced to do yesterday), I have to create a new Guardian every time I put my headset on(Which is a lot since I've been developing a OVR game).  "Guardian Not Found". This behavior has really slowed down my development time.  I haven't changed positions in my office chair and the lighting hasn't changed in the room.  I have cleared guardian history but that hasn't helped.  Please help!
EDIT:  I should note that I am using a stationary guardian in a sitting position and am in AirLink during development testing.

Level 2

Same problem as @musiccreatures. Since an update over the past couple of weeks, my guardian resets every time I put my headset on - even in the exact same position in the exact same room, and even with a stationary boundary. If I try to walk around, or between rooms, no previous guardians in any rooms are detected.

Level 4

Constantly resetting here, room is well lit, lighting makes little difference, I remember the hmd worked really well when I first got it but has been becoming more unbearable with recent updates. Asks to resets guardian often now, and forgets guardian often after being turned off. I am not sure why updates feel like downgrades, but can you please fix Quest to work like it was in earlier versions.

Hiya, airmouse! We see you're having an issue with your Guardian resetting, making your device unplayable. To try and resolve this issue, please visit this article on our public support site. If that article doesn't help, please submit a support ticket on our support site, and make sure to include all details regarding your issue. Thanks! We hope you find this information helpful. 

There's not much I can do to fix it, mostly it has to do with UX of the Quest in general. The Quest is great, but it takes forever to recreate the guardian.

Still having this issue as well and its is now July 2022  😕 

Level 2

Hey I have this problem to but mine it just lose track and glitches back to my boundary for 2 or 1 sec then goes back to normal and keeps RESETING! Thank god that I’m not the only one because I thought my headset was useless lol…


Aybmu icr🤣




KARAN LbyFk issv z

Level 6

I find that clearing the Guardian after a headset update helps.


In another thread another post said she/he found a hack online that if you cover/block one of the lower cameras on the headset while creating the Guardian fixes the problem.


I haven't tried this myself as I haven't had a Guardian problem since reading about the hack.