cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 not Charging via USB C even with adapter

kuba.szymko
Level 2

Recently Im having problems having Quest 2 battery being up for longer periods of taking via PCVR. My first 3rd party link cable did keep battery up pretty well, but started having connection issues so I decited to get C-C cable. Cable works fine to play PCVR, but dosen't keep battery, even downright drain it. Decited to get Beasus USB C to A adaptor, still works to play games but not keep battery for longer. Anyone knows what's wrong? The Mobo that had USB C port that I tried to use was ASUS TUF Gaming X570-Plus

3 REPLIES 3

kuba.szymko
Level 2

I should also point out that I tried turning autowake off, auto wakeup off, tried diffrent USB slots, disabled data transfer. Still having 0 mA, but on the faulty link I still had about 893 mA which was C-A cable.

Hi there! We would love to assist you with your power issue! Some cables have the ability to charge and some only have the ability to just connect. 

 

We suggest using our Oculus cables only. However since your issue persists after trying multiple cables, we suggest that you submit a support ticket here so that we can assist you directly. 

 

 

PITTCANNA
Level 13

You need to get a powered usb cable.  some headers simply can't supply enough power to the headset.

https://www.amazon.com/Kuject-Separate-Charging-Ultra-Durable-Accessories/dp/B09TN25765/ref=sr_1_1_s...