cancel
Showing results for 
Search instead for 
Did you mean: 

Rift preventing Computer from going to sleep

Nibre
Level 5
I was trying to setup 'Put the computer to sleep' in my Power Options, but noticed that something is preventing it from actually kicking in. 

By running powercfg -requests in Powershell, I get this;
DISPLAY:
None.

SYSTEM:
[DRIVER] Realtek High Definition Audio (HDAUDIO\FUNC_01&VEN_10EC&DEV_1220&SUBSYS_10438735&REV_1000\5&1e493937&0&0001)
An audio stream is currently in use.
[DRIVER] Oculus VR Headset (USB\VID_2833&PID_0330&MI_00\9&3a680418&2&0000)
An audio stream is currently in use.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.
So it looks like it may be the Rift keeping it awake. If I manually put the Computer to sleep, it works fine (other than the Headset alert), but timed sleep just refuses to kick in on its own. I don't have any games running or anything, and the headset is put away (still plugged in, but asleep with the Amber light). For reference, I am on Windows 10 1607, and Oculus 1.12.0.347531.

Testing;
If go into Devices->Rift, and change my Audio Output to Rift only (instead of Mirroring), the Realtek entry disappears from 
powercfg -requests. So that is definitely causing that one. Then, if I close the Oculus app, the Oculus entry disapears too. Timed sleep then starts to work correctly, until the App is opened again.

If I instead leave Audio Mirroring enabled, neither of the entries disappear when I close the Oculus App. In fact, the only thing that seems removes them at that point is manually Stopping the OVRService, or just turning off Audio Mirroring and closing the Oculus App.

Conclusion;
So it appears that there are 2 issues here, due to Audio Streams.
  • Issue 1 - Having the Oculus App running, while the Headset is dormant and no VR is active, prevents timed sleep until the App is closed. (This may be intentional, but can be pretty annoying. It should let it sleep if nothing's currently happening, and prevent it when it needs to)
  • Issue 2 - Having Audio Mirroring enabled prevents timed sleep from happening whatsoever, until the OVRService is Stopped or Mirroring is disabled. (Seems to be because Mirroring continues to work after the App is closed. It'd be nice if it still allowed sleep to work somehow. Maybe add an option to only Mirror if VR things are happening, instead of 24/7?)
Partial Fix;
I've had mixed luck getting powercfg -requestsoverride to make it ignore the Audio Streams.
By using this, it will sometimes work after a Reboot, but doesn't seem to consistently work after that. Very hit and miss for me.
powercfg -requestsoverride DRIVER "Realtek High Definition Audio" SYSTEM
powercfg -requestsoverride DRIVER "Oculus VR Headset" SYSTEM


Figured I'd post this here to give you guys a heads up, or see if I'm missing something. Thanks!
10 REPLIES 10

TwoHedWlf
Level 11
Make sure you close Oculus Home.  I find if it's on it won't let my PC sleep(Or keeps waking it up after a while, hours even.  How?  I don't know)  But if it's closed before putting it to sleep, it's fine.

cybereality
Level 15
My computer won't stay asleep for more than an hour or two. I'm sure I've disabled everything that I could find. I wonder if this issue you mention is the reason.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

TwoHedWlf
Level 11


My computer won't stay asleep for more than an hour or two. I'm sure I've disabled everything that I could find. I wonder if this issue you mention is the reason.


Have you tried end tasking all the oculus tasks before putting it to sleep?  I seriously don't see how a running application could cause it to wake up after it's been asleep a while but that does seem to be the case.  Maybe sleeping computers dream and Oculus Home gives them nightmares?

weasel47
Level 7
My computer also wakes up after being asleep for a little while.  I usually shut it down instead of putting it to sleep.  Even crazier, sometimes it even turns itself back on immediately after I tell it to shut down!  Could it have something to do with HDMI or USB?  I know a sleeping computer can be woken up with a mouse wiggle or keystroke, so maybe a USB or HDMI disconnect / reconnect is occurring and triggering the same thing.

danybonin
Level 4
If the computer wakes up, its because he have sleeped enought. Don't try to force him to sleep if he is not tired...
core i7 5930k @ 4.4ghz
nvidia rtx 2080 ti
16GB ram
asus pg27uq
oculus cv1 4 sensors on usb3 on 5 distinct usb controller

Dimebonix
Level 2

weasel47 said:

My computer also wakes up after being asleep for a little while.  I usually shut it down instead of putting it to sleep.  Even crazier, sometimes it even turns itself back on immediately after I tell it to shut down!  Could it have something to do with HDMI or USB?  I know a sleeping computer can be woken up with a mouse wiggle or keystroke, so maybe a USB or HDMI disconnect / reconnect is occurring and triggering the same thing.


Sounds like some poltergeist shit to me.

In all seriousness, I happened upon this page for the exact same reason. So what are we concluding is the most reasonable fix at this time? Just ending the OVRservice process in the task manager? That could be a pain in the butt having to do that every time.

thebius
Level 2
Why is this still not fixed 3 years later. It's a pain in the butt.

dharlequin
Level 2

It's 2022, and the problem is still here. I have closed Oculus App, I have disabled Oculus input/output in Sound Devices, yet it still occupies Audio Stream and prevents PC from going to sleep on it's own.

Hey dharlequin! Auto-sleep features in Windows is absolutely imperative for the convenience sake of saving battery life (if you have a laptop) and just keeping that electric bill down (seriously, it can really rack up if you aren't careful). There are a few different ways you can work around this issue. The OP mentioned 2 of them, but there are 2 more you can feel free to try. Some users have had success making a batch file to speed up the process of stopping and starting the OVRService process. You can pretty easily find steps on how to do that through some forums and websites.

 

If you can live without the auto-sleep function, you can also create your own Windows shortcut for putting the PC into sleep mode manually. The only caveat is that you need to disable hibernation mode, as the shortcut will auto default to hibernation mode if it's enabled. Disabling hibernation mode requires PowerShell (Admin) tinkering, so we suggest looking up guides on how to do that as well.

 

Seeing as this is technically an idea for adding auto-sleep friendly features to the Oculus app, it wouldn't be a bad idea to create a thread on our Ideas board, as it will likely gain more traction and feedback from the community!