cancel
Showing results for 
Search instead for 
Did you mean: 

SOLVED - Oculus Quest 2 fails to connect to pc via cable and airlink

souper_soap
Level 2

Every time I connect to my PC, the visuals are black (yet I can hear sounds such as notifications from my PC) and oculus tells me that "Hardware Problem. Oculus isn't working correctly. Click here to check our support article." It also says there's a "General Device Problem" in the oculus app and shows a orange circle.

 

I have tried resetting my PC, VR, tried different ports, I don't have an extra cable so that I can't do. I heard it was from some sort of update that is centered around NVIDIA GeForce GTX 10xx series notebook GPUs, and that I need to reset my computer for a temporary fix. I have reset my computer, and I don't even have a 10xx. I have a NVIDIA GeForce GTX 1660 Ti, although I do have a notebook, but, I also have an integrated AMD Radeon(TM) RX Vega 10 Graphics. I have never had these problems before. Last time I put it away, it was working perfectly, and then it stopped working. The main Oculus menu works perfectly, it's just that I can't connect right to my PC. Is there any way I can fix this/get around the update? Or do I have to wait for a fix, or is something else wrong?

 

EDIT: I fixed it, apparently my graphics drivers were so out of date that it couldn't support Oculus.

1 REPLY 1

souper_soap
Level 2

Correction, I have an Oculus Quest 2, not an Oculus Quest*