Showing results for 
Search instead for 
Did you mean: 

Setup Can't connect

Level 3
The new setup keeps telling me "Looks like we can't reach the Oculus server. Please check your connection."
I disabled my firewall (Windows 10), but it keeps failing. 

Does anyone know what's wrong?


Level 2
So it seems like a network issue, just dealt with 5 hours of installing oculus and this is what I did to fix it
1. completely turn off all firewalls and anti-virus (COMPLETELY)
2. Update your drivers with GeForce experience
3. Make sure you have an Internet connection
4. Unplug your oculus from the PC (hdmi, sensor USB, HMD USB)
5. Restart PC
6. Try again

Level 3

After a bit of research, I believe that it has nothing to do with firewalls or antivirus.

I found out the OculusSetup.log in AppData\Local\Oculus, and there is an exception thrown by the installer when trying to config the endpoint:

System.Net.WebException: An exception occurred during a WebClient request. ---> System.Configuration.ConfigurationErrorsException: Error creating the Web Proxy specified in the '' configuration section. ---> System.DllNotFoundException: Unable to load DLL 'rasapi32.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
   at System.Net.UnsafeNclNativeMethods.RasHelper.RasEnumConnections(RASCONN[] lprasconn, UInt32& lpcb, UInt32& lpcConnections)
   at System.Net.UnsafeNclNativeMethods.RasHelper.GetCurrentConnectoid()
   at System.Net.AutoWebProxyScriptEngine.AutoDetector.Initialize()
   at System.Net.AutoWebProxyScriptEngine.AutoDetector.get_CurrentAutoDetector()
   at System.Net.AutoWebProxyScriptEngine..ctor(WebProxy proxy, Boolean useRegistry)
   at System.Net.WebProxy.UnsafeUpdateFromRegistry()
   at System.Net.WebProxy..ctor(Boolean enableAutoproxy)
   at System.Net.Configuration.DefaultProxySectionInternal..ctor(DefaultProxySection section)
   at System.Net.Configuration.DefaultProxySectionInternal.GetSection()
   --- End of inner exception stack trace ---
   at System.Net.Configuration.DefaultProxySectionInternal.GetSection()
   at System.Net.WebRequest.get_InternalDefaultWebProxy()
   at System.Net.HttpWebRequest..ctor(Uri uri, ServicePoint servicePoint)
   at System.Net.HttpRequestCreator.Create(Uri Uri)
   at System.Net.WebRequest.Create(Uri requestUri, Boolean useUriBase)
   at System.Net.WebRequest.Create(Uri requestUri)
   at System.Net.WebClient.GetWebRequest(Uri address)
   at Dawn.DawnWebClient.GetWebRequest(Uri address)
   at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
   --- End of inner exception stack trace ---
   at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
   at System.Net.WebClient.DownloadString(Uri address)
   at Dawn.DawnSession.InitialiseAsync()

I tried to run the same setup file in another computer and it works just fine, this exception only appears in my workstation.  

Has anyone run into the same problem? 


Level 3
Sorry, I forgot to attach the log file. 

Thank you. 

Level 3
Hi All, 

I finally solved the problem. For some reason there was a problem reading the proxy configuration of my pc. I bypassed this in the setup application creating a separate app.config file and setting the defaultProxy enabled = false. 

I attach the file in case someone runs into the same problem. Just unzip the config file attached and place it in the same folder of OculusSetup.exe and you should be fine.

Level 2
@jawatr thank you!

Level 3
genius, worked however i get network issue once its downloaded and installed when i try to login. The app wont access the network. All firewalll is off.

Level 3
ok sorted for some reasons i had internet options to use a proxy, i changed to use no proxy and everything is fine.

Level 2
did not work for me still cant connect to server

Level 2
Yea I am not sure what folder to put it the file in after its unziped.  I put the .exe and the config file into a new folder on my desktop and it didn't work.