cancel
Showing results for 
Search instead for 
Did you mean: 

Stuck in three dots and can't get my rift s to work after oculus last update

liyi.289743
Level 3

The last time I used Oculus was August 27th. After it was prompted that the app needed to be updated, I did the update, and then the rift s couldn't start anymore, it kept stuck at the 3 dots startup screen.

 

I followed the official and others' tips,and have done the following operations..

 

· reconnect the usb
· update my graphics card driver
· reinstall oculus
· recover operating system win11 to August 16
· Update all hardware drivers
· Use an independently powered PCI to USB card


But these operations are useless, rift s still can't work properly.

 

liyi289743_0-1662185610811.png

liyi289743_1-1662185634624.png

liyi289743_2-1662185642741.png

 

Also,only one rift s usb hub displays in my device manager.I saw some posts saying that it is normal to have 2. I don't know if this is the reason.

liyi289743_3-1662185742170.png

 

I hope I can get your help.

Thank you.

34 REPLIES 34

Hey there! We know what it's like to want to game but run into issues. We'd love to help you.

 

We have provided you with a link of the minimum system requirements for you HERE. We hope you find it as helpful as we have.

kurry
Level 4

I don't have a b450 motherboard, but still have the problem. I got desperate and tried with a fresh windows install and it still doesn't work.

This issue seems to be brought up by at least one person daily on the Oculus subreddit, so it can't be a hardware issue and more likely something Oculus broke in an update.

Hello! Thank you for pointing this issue out to us. We definitely understand your concern. You shouldn't be having issues with the display after the software update! We'd like to get you back to playing the headset, so there are a few troubleshooting steps we can try out.

 

 

Try these steps below:

 

  • Make sure your headset and primary monitor are connected to the same video card. 
  • Make sure to remove and adapter form the headset. 
  • Disconnect cable from PC and reboot PC. 
  • Ensure the cable is not damaged in any way. 
  • Update your Graphics card.  

 

Let's ensure your PC is compatible using this link. If you need steps to update your GPU, we need to verify what type of GPU you currently have. Please let us know if you have any issues.

Hey again! We just wanted to check back in with you. Did you still need assistance?

Badno
Level 3

I just tried to log into today with my Rift S and I'm having the exact same issue after updating to the Meta account. I hadn't played for a couple weeks as well. This is super frustrating.

Raxsor210
Level 3

I changed my entire pc and rift s cable to make sure to the oculus dev are just ignoring us and let them stop saying it's our fault or pc bad, because everyone have rift s when come out. they try to teach the basic stuff like a kid when is litteraly the app. 😂 then they try let buy that pepega quest 2 like a toy,  if the oculus give the access to the previous version nobody will have problems, like other company > bad update just rollback

Badno
Level 3

Badno_0-1663279652154.png

I've been working on this all day. I've tried so many solutions. All of this after the Meta account nonsense. 

 

WildEden
Level 3

I have the same issue.. Headset sensor check. From what I've seen many are saying the USB 3.0 drivers are being blocked by Oculus. So if that's the case a simple unblock from oculus would suffice... Nothing wrong with any of the 9 usb ports I've tried today and yesterday and yet 3 dots and this crappy sensor issue. 
If the USB 3.0 block is actually a thing then that is a whole new level of middle fingers to users...
I have uninstalled, reinstalled, unplugged, plugged in and restarted my computer so many times today with no luck Im about to throw this headset out the window... Fix your s**t

damoran
Level 2

I'm having the same issue. Had shelved it about a year ago after intermitten issues in the few games I play with this. My favorite game (beat Saber) couldn't track the hand controllers fast enough for expert plus mode so whatever, I had issues with random disconnects back then, unplug/replug worked most of the time but was always glitchy. I come back to it yesterday plug it in like usual (still had everything installed) and got the exact same issue as described above. 3-dots in the headset, oculus software reports headset cannot be tracked. USB drivers report issue. I tried getting it working for about an hour then gave up figuring it was the cable but perhaps it's something to do with the latest update and drivers. Any update to this from support would be great. Thank you

I honestly dont think Support here care anymore. Rift S is no longer available to purchase and they no longer support the headset. Thinking we're gonna be dumb and buy future releases when we know they are just gonna brick them and bring out new crap. Im done with Oculus at this point