cancel
Showing results for 
Search instead for 
Did you mean: 

Stuck in three dots and can't get my rift s to work after oculus last update

krazyivan008
Level 3

my pc is above minimum spec i still get sound from oculus home but im only seeing the three loading dots and thats it how do i fix ?

3 REPLIES 3

OculusSupport
Community Manager
Community Manager

Hey there! We know how dismaying PCVR issues can be, so we'd be more than glad to lend a helping hand. 

 

In order to gain some insight, could you please answer the following:

 

  1. When was this first noticed?
  2. Has the Rift S worked well before by chance?
  3. Did anything change around the time when this was first noticed?
  4. What are your current PC specs? (OS, RAM, GPU Type and version, CPU)
  5. What all have you tried already? (So to not repeat anything)

 

Along with this, we do have a couple of basics to try for now:

 

  1. Check your GPU for updates.
  2. Check Windows for updates.
  3. Check your Oculus drivers:
    1. Close the Oculus app.
    2. Press the Windows key + R on your keyboard to open the Run command.
    3. Enter C:\Program Files\Oculus\Support\oculus-drivers.
    4. Open oculus-driver.
    5. Open the Oculus app and then try to connect your headset again.

 

Looking forward to your update! 

the issue started when i had to switch over from oculus to meta platform i have since then tried every work around you your support team has given myself to try and still can't fix the issue i have been in contact with oculus support and they asked me to send oculus back to them and they will send me a replacement i am just awaiting the the shipping label to be sent via email so i can send to oculus distribution centre 

That's wonderful to hear! 

 

We hope you're able to enjoy that headset once it pops in. If you run into any other issues, don't hesitate to reach back out anytime! 🙂