cancel
Showing results for 
Search instead for 
Did you mean: 

unable to add payment method and the wild amount of people that have this problem

Bronzliy
Level 2

I'm not allowed to add a payment method I've even did all the things they told me to do and well... nothing... radio static for a few days.

  • Recently made a successful online purchase from a US merchant? Yes.
  • Check to see if the financial institution placed any restrictions? Yes.
  • Try another network connection type: I did. Didn't work.
  • Try another network location: I did. Didn't work.
  • Try different combinations of the area/zip code: I did. Didn't work.
  • Restart the device: I did. Didn't work.
  • Try another device: I did. Didn't work.
  • Try another payment method: I did. Three separate cards.

 

Its crazy the amount of people that have this problem meta needs to fix this right away, I'm trying to buy into the radius and bonelab but I cant cause something is wrong with the payment methods...  pleeeeeease help us meta and get this fixed soon.

15 REPLIES 15

luther_1
Level 2

You arent the only one true im having the same problems and i thought i was the only one having then 

SaxMarine
Level 3

I also have this problem too. Meta really needs to fix this, especially due to the huge amount of hype that Bonelab has.

BougieBanton
Level 3

How is there no fix for this yet when it's clearly on their end and not our credit cards or bank account? Need help

Krownos
Level 3

This is amazing, we're actively trying to buy things on their system and somehow it doesn't want our money! How did they make it impossible to add and spend money? Why can't they just make money cards for oculus. Seriously, Xbox does it PlayStation does it Nintendo does it Steam does it, this problem would be solved if they just keep up with the times. Just want to play bone lab dammit.

Raidergar
Level 3

Oculus Support, you should have a readily available and easy to find solution for this. Every fix I see for this from you is explaining how to add a payment method. No one has trouble trying to add one! They are having trouble getting it accepted! Come on!

HJohnson_III
Level 3

Same problem here with a brand new Quest 2 that I bought yesterday.. I contacted support via chat and after being told to do allll the things that they already know wont do anything, they told me this is a known/widespread issue that they are trying to fix.

What’s stupid is that I’ve seen people having this issue and finally get it fixed by Meta and Meta is not fixing the issue for everyone. 

Raidergar
Level 3

OK, I can tell you what just  worked for me, finally. I went onto the headset and tried to purchase a game and it asked me to enter a payment method. While I was doing that and putting in the expiration date for my card, it was telling me that I needed to put in a correct date. I was entering 04/26 like my card says on it. But when I put in 04/2026, it excepted it. Now I can’t say for sure if it was because I was on the headset or if it was because I put in the full year on the expiration date. But it worked for me.

Bruh, I literally have been doing that all this time. I put the full year and it doesn't work.