cancel
Showing results for 
Search instead for 
Did you mean: 

AppLab submission failed VRC.Quest.Functional.3 (user gets stuck)

jboss
Level 3

I submitted my Quest application to AppLab and got the feedback that it does not pass VRC.Quest.Functional.3. This is the requirement that the user shall not get stuck in the experience. The remark was that the user got stuck in the main menu.

 

I have tried to reproduce the issue in many ways:

I have run the app for 45 minutes, tried all scenes and back to the main menu, shortpressed the Oculus home button and then resumed the app. Recentered the app and continued. Made a photo and a video and resumed. Took off the headset for 10 minutes and resumed the app.
Everything worked fine.

 

I asked Oculus for some more context, so that I can troubleshoot this, but they could not give more details. Fair enough, they get so many apps these days.

 

Has anyone experienced this before? Any suggestions on why this may have happened?

 

Thanks!

3 REPLIES 3

eVInteractive
Level 3

FWIW, a common QA test is to do the Main Menu to gameplay "round trip" 50 times in a row to stress test memory usage, etc.  Not sure if they do that at Oculus, but might be something to try.  Unfortunate that you did not get more detail.  Perhaps post your report here and maybe somebody can help you read between the lines?

jboss
Level 3

Thanks for the tip, I'll give it a try.

 

This is the info I got in the test results. Should there be a more detailed test report?

VRC_Quest_NotPassed.png

 

jboss
Level 3

I have created a new version and I still get the failure. This time more concrete info:

TEST BLOCKER - Immediately after launching the application, the application is unresponsive when selecting any options on the main menu. Nothing occurs when selecting "Strikezone" or any other options on the menu.

 

I did have this problem while I was working on the updates as well. I think it was related to the fact that I needed to go through Android Studio to create the build without the unnecessary Oculus Integration package AndroidManifest options (microphone/bluetooth) as described here:

https://skarredghost.com/2021/03/24/unity-unwanted-audio-permissions-app-lab/

 

But when I now download the AppLab build apk and install it on my Quest it works fine.

 

Is there any reason why the behaviour on the test device is different from the behaviour on my device? Developer mode?