Showing results for 
Search instead for 
Did you mean: 

Help! Gear VR software will not install on Galaxy S6

Not applicable
Device: Galaxy S6 (SM-G920P)
Android Version: 5.1.1
Carrier: Sprint (But not activated/Wi-Fi only)
Details: Fresh, Factory-reset device. 24GB available.

I received my Gear VR this week, but I've had no luck in getting it to run. I put my Galaxy S6 in, and it completes the initial install, lets me login to my Oculus account, but will not install any of the Oculus apps or update "Oculus System Activities" once I reach that step.

Once it gets to the "Oculus 360 Photos" app, etc, it just starts erroring out. When I tap "Update Now" for the "Oculus System Activities" update, it appears to download something but it never actually updates. So, I'm stuck in a loop of nothing working. Plugging the phone into the Gear VR just shows me a message that it needs software installation to finish on the device.

I've tried everything I can think of: I've done an on-device factory reset, I've restored the device with Samsung Smart Switch, I've uninstalled the Oculus apps and tried again after restarting- nothing.

The only anomaly I can think of is that I do not have an active plan assigned to the S6 and it's wi-fi only (it's a work/dev device and does not have a carrier plan, although it is a Sprint device). The only thing I can imagine is there is a specific carrier setting that would require an OTA update to support the Gear VR... but that's a stretch IMO.

Overall I'm really disappointed and sad I haven't been able to get anything to work, or find anything online about fixing it.

Can ANYONE help me figure out how to get this working? Is there a way to adb the "Oculus System Activities" update onto the device? Or a way to update that doesn't rely on the system that isn't currently working?

Thank you.


Level 2
Maybe app requires access to SIM card and/or phone number which are not present as the phone has no SIM card inserted?

Level 2
make sure you are not using any speed boosting programs that block ads or stuff because oculus is owned by facebook they use facebook servers so some cleaners block certain calls to facebook

Level 2
I'm just about to buy a Note 5 without a cell service plan either and am curious if that is a requirement as well. Can anyone confirm being able to use the consumer GearVR on a S6 or Note 5 without it ever connecting to cell service?

Have you tried plugging your S6 into your computer after the Update Required message shows up to do an adb logcat to see if there are any interesting messages saying why it won't work?

Not applicable
I have an S6 with no phone plan and have never used cell service. Both it full price att s6 so need for contract.
All updates via wifi.
Connection to Mac only to download videos and built apks for testing.

Level 2
hello guys,

after a while i tried to connect my gear vr innovator edition to my note 4 again.

it does not recognize the phone at all.

i am using the carrier free german firmware 5.1.1 and made sure the phone isnt muted
i tried to connect the micro usb as good as possible but it wont make any connection.

what else could i try?

Level 2
i would back your phone up and try hardware reset on it with a fresh install, then try gear vr. this is a last resort though because it requires redownloading your apps and games and if you don't back up you will lose your videos and pictures

Level 2
Mine worked okay, just got it today... Try starting over, and delete the oculus software etc

Level 2
I made it with a Shortcut app while I unplugged the GearVR

Not applicable
I appreciate all of your responses, but as stated in my initial post- this is a FRESH, FACTORY RESET device. There is no software that blocks services or activities, etc.

I've also uninstalled/reinstalled/factory reset several times with no success. It is also running the latest firmware/software (Android 5.1.1)