cancel
Showing results for 
Search instead for 
Did you mean: 

[Kinda solved] Rift S disconnecting after a few minutes, then reconnecting by itself

Salticus
Level 2

"Fix": It appears that my cable was broken, I contacted support and got a new one withhin a week, even though I'm pretty sure the warranty already expired. I had no problems at all so far. So if you experience similar problems, make sure to look at your cable toroughly and probably contact support.

 

Edit: Well, after not getting to use the headset for like a month, I tried it again today and get no display port connection at all. After close inspection it seems that my cat chewed on the cable and it's broken. Thanks to Oculus I can't get an official new cable, and inofficial ones are 150€+, I'll try to contact support.

 

So since about a month ago my 2 year old Rift S just crashes after about 20 minutes (Sometimes more, sometimes less) of use. I don't remember anything changing between it working and not working. Both SteamVR and Oculus games are affected. The picture suddenly just freezes and there's a high pitched sound. Then there's a disconnect sound, I hear very loud static and the headset goes black. The LED then turns red and the Oculus Software tells me to reconnect my Display Port cable, however after about a minute of not changing anything the Headset reconnects by itself and everything works perfectly again for the next 20 minutes. During the time where it shows a black screen, the games run in the background, and my PC still works, but my mouse and keyboard are basically frozen. Because of that I suspected that maybe my PC was just not powerful enough to handle some moments in these games, but it also crashes while playing Gorilla tag, so I doubt that it's an issue with my PC. I also don't think the issue is the cable physically disconnecting, since I also had it happen in seated games in moments where I didn't make any sharp movements.

 

What I've tried so far:

  • Trying every possible Display Port
  • Trying every possible USB 3.0 port
  • Turning off everything connected to my PC except for one screen, my mouse and my keyboard
  • Updating Windows and my Nvidia drivers
  • Removing the Rift S USB hubs in the device manager
  • Reinstalling the Oculus App
  • Making sure that power save if off for the USB ports
  • Replugging the cable on the headset side
  • Changing the sound output device to something other than the Rift S

And my PC Specs, in case it matters:

  • Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz 3.19 GHz
  • 16 GB Ram
  • 64 Bit
  • Geforce GTX 1070
1 REPLY 1

OculusSupport
Community Manager
Community Manager

Hey Salticus! Having your Rift S disconnect then reconnect on its own is definitely an issue that needs to be resolved. Thank you for laying out your current troubleshooting steps. Your current OS may need to be updated, and we will need a little bit more information from you, such as a log, etc. So we highly recommend that you place a support ticket with us so one of our specialists can take a deep dive into your issue. Thank you!