cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 Windows 11 Performance. can never hit maximum FPS with link cable.

Gifted83
Level 4

I decided to give windows 11 a go and everything on my PC is working flawlessly apart from one big one... Oculus Link performance. Before I go back to windows 10 I wonder if anyone has figured this out already.

 

Oculus software works fine and the Quest 2 link connects, but it can never hit the required fps settings no matter what they are. So if I have link set to 90hz, then in game it will be about 82-85fps and stuttering, it never hits 90fps even though the game says its locked at 90 on my monitors no problem, and I have loads of headroom in performance monitor (I have a 5900x and RTX 3090!) - If i use the 120hz option then i will get about 105fps but never 120. Even if i choose 72hz ill get about 65fps. super annoying.

 

I went onto the beta channel on the software and got the latest updates but still no luck.

 

I dont mind going back to windows 10 and i get windows 11 might not be ready yet, but literally EVERYTHING else on my pc works fine, only the vr performance, so its a shame. Any ideas of things to try before I reinstall windows 10?

320 REPLIES 320

papuSpartan
Level 4

ifonlyyouknewhowbaditreallyis.png

literally forgets what my name is within the span of 2 minutes 🤡

alexvojacek
Level 4

I would add that it is not just you but basically most of Windows 11 users being affected by this. Worse still. It is super easy to replicate and I've state this a thousand times.  

You have unlimited resources at Oculus so it is really an insult that they come over here and suggest us to open a support ticket when you can just SPARE A FEW FREAKING MINUTES to install Windows 11 yourself and test this bug.   Everyone can create the circumstances of this bug in minutes.    If you still did not solved this issue is because it is not a priority and not because it  can't be done.

alexvojacek
Level 4

Feel free to hire me as community manager for Oculus.  I would just admit that my company is lazy and will try to find a workaround while the geniuses in the dev department come into a solution.  Ignoring the situation and redirecting people to support is not fun and it is making you look bad.  Just put yourself into people's shoes.

 

Some of us purchased a Quest 2 to use on a high end PC with latest hardware and software. Apparently "latest software" is something not contemplated at Oculus.

Windows 11 isn't supported just yet. We don't have a timeframe to give on when it will be, but we're hard at work making sure the Oculus experience is ready to take the leap into the Windows 11 environment. 

 

It's been out for almost 2 months and it seems like Oculus is more or less the only software out there that isn't compatible by now. Congratulations.

 

 

CactusCowboy_0-1638517828982.png

 

LameDuckWarrior
Level 7

The sound of silence.

Mike12306
Level 5

Okay, I think we've seen enough here. Every reply doesn't indicate caring at all about this issue.  They'll get to it when they do I guess. The operating system has been in preview way before it was released for the sole purpose of developers being able to release software and get ready for it when it came out officially. Meta didn't put this as a priority. It's officially out and since everything else works perfectly with this OS, most people are moving towards it. Like most people, when a company behaves like this, we just move on. I will continue to use the Quest 2 for now. It would be silly  (not to mention wasteful) to ditch the headset and buy another right now for anyone who isn't already looking for a new headset but when I come to the point that I want to upgrade, I certainly wouldn't touch anything from Meta. I think most of us feel the same.  Like any other company that behaves this way, they lose customers in the end.

Imagine pushing V35 to PC without including a Win11 fix. I'm starting to wonder where they have outsourced the development to?

That is exactly what I'm going to do. Support and proper drivers is 50% of your product.  You can have a dream VR headset but without proper support and drivers, it is close to being useless.

Seems like it.  Any experienced developer could detect and troubleshoot this issue in a day or two.  Replicating the issue is fairly easy now so troubleshooting should take no more than that.  Fixing may take longer but not so much if you already have a way to replicate it.

This feels like the bug was "reported" and then got stuck in some spreadsheet and nobody is taking on the role to fix it.

this is the only thing that worked for me. thx man!